您的位置:首页 > 其它

HDU 4496 D-City(并查集删边)

2016-03-15 10:32 295 查看

D-City

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65535/65535 K (Java/Others)

Total Submission(s): 2914    Accepted Submission(s): 1033


[align=left]Problem Description[/align]
Luxer is a really bad guy. He destroys everything he met.

One day Luxer went to D-city. D-city has N D-points and M D-lines. Each D-line connects exactly two D-points. Luxer will destroy all the D-lines. The mayor of D-city wants to know how many connected blocks of D-city left after Luxer destroying the first K D-lines
in the input.

Two points are in the same connected blocks if and only if they connect to each other directly or indirectly.
 

[align=left]Input[/align]
First line of the input contains two integers N and M.

Then following M lines each containing 2 space-separated integers u and v, which denotes an D-line.

Constraints:

0 < N <= 10000

0 < M <= 100000

0 <= u, v < N.

 

[align=left]Output[/align]
Output M lines, the ith line is the answer after deleting the first i edges in the input.
 

[align=left]Sample Input[/align]

5 10
0 1
1 2
1 3
1 4
0 2
2 3
0 4
0 3
3 4
2 4

 

[align=left]Sample Output[/align]

1
1
1
2
2
2
2
3
4
5
Hint
The graph given in sample input is a complete graph, that each pair of vertex has an edge connecting them, so there's only 1 connected block at first.
The first 3 lines of output are 1s because after deleting the first 3 edges of the graph, all vertexes still connected together.
But after deleting the first 4 edges of the graph, vertex 1 will be disconnected with other vertex, and it became an independent connected block.
Continue deleting edges the disconnected blocks increased and finally it will became the number of vertex, so the last output should always be N.

 

[align=left]Source[/align]
2013 ACM-ICPC吉林通化全国邀请赛——题目重现
 

[align=left]Recommend[/align]
liuyiding   |   We have carefully selected several similar problems for you:  5644 5643 5642 5641 5640 
并查集的逆向思维,删边。删掉第一条边等于加上m-1条边
#include<stdio.h>
#include<string.h>
#include<algorithm>
#define M 100000+10
#define N 10000+10
using namespace std;
int n,m;
struct node
{
int u,v;
} edge[M];
int pre
,ans[M];
int fine(int x)
{
if(pre[x]!=x)
pre[x]=fine(pre[x]);
return pre[x];
}
int main()
{
int i;
while(~scanf("%d%d",&n,&m))
{
memset(ans,0,sizeof(ans));
memset(edge,0,sizeof(edge));
for(i=0;i<n;i++)
pre[i]=i;
for(i=0; i<m; i++)
{
scanf("%d%d",&edge[i].u,&edge[i].v);
}
int sum=n;
for(i=m-1;i>=0;i--)
{
ans[i]=sum;
int fx=fine(edge[i].u);
int fy=fine(edge[i].v);
if(fx!=fy)
{
sum--;
pre[fx]=fy;
}
}
for(i=0;i<m;i++)
printf("%d\n",ans[i]);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: