您的位置:首页 > 其它

HDU1071 The area

2016-03-15 10:16 211 查看

The area

[b]Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 9349    Accepted Submission(s): 6591
[/b]

[align=left]Problem Description[/align]
Ignatius bought a land last week, but he didn't know the area of the land because the land is enclosed by a parabola and a straight line. The picture below shows the area. Now given all the intersectant points shows in the picture,
can you tell Ignatius the area of the land?

Note: The point P1 in the picture is the vertex of the parabola.



 

[align=left]Input[/align]
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.

Each test case contains three intersectant points which shows in the picture, they are given in the order of P1, P2, P3. Each point is described by two floating-point numbers X and Y(0.0<=X,Y<=1000.0).

 

[align=left]Output[/align]
For each test case, you should output the area of the land, the result should be rounded to 2 decimal places.

 

[align=left]Sample Input[/align]

2
5.000000 5.000000
0.000000 0.000000
10.000000 0.000000
10.000000 10.000000
1.000000 1.000000
14.000000 8.222222

 

[align=left]Sample Output[/align]

33.33
40.69

Hint
For float may be not accurate enough, please use double instead of float.

 

[align=left]Author[/align]
Ignatius.L
根据顶点式求出a,对称轴求b,代入求出c和直线方程,定积分求出面积
#include <stdio.h>
#include <algorithm>
using namespace std;
struct node{
double x, y;
}p[5];
bool cmp(node a, node b){
return a.x < b.x;
}
double a, b, c, k, d;
double x1, y1, x2, y2, x3, y3, f;
double func(double x){
return a*x*x*x/3+b*x*x/2+c*x-k*x*x/2-d*x;
}
int main()
{
int T;
scanf("%d", &T);
while(T--){
scanf("%lf %lf %lf %lf %lf %lf", &p[1].x, &p[1].y, &p[2].x, &p[2].y, &p[3].x, &p[3].y);
a = (p[2].y-p[1].y)/((p[2].x-p[1].x)*(p[2].x-p[1].x));
b = p[1].x*(-2*a);
c = p[2].y-a*p[2].x*p[2].x-b*p[2].x;
k = (p[3].y-p[2].y)/(p[3].x-p[2].x);
d = p[2].y-p[2].x*k;

sort(p+1, p+4, cmp);
printf("%.2lf\n", func(p[3].x)-func(p[1].x));
//getchar();
//getchar();
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  hdu 数学