您的位置:首页 > 其它

1108. Finding Average (20)

2016-03-14 23:18 429 查看

1108. Finding Average (20)

时间限制400 ms内存限制65536 kB代码长度限制16000 B判题程序Standard作者CHEN, YueThe basic task is simple: given N real numbers, you are supposed to calculate their average. But what makes it complicated is that some of the input numbers might not be legal. A "legal" input is a real number in [-1000, 1000] and is accurate up to no morethan 2 decimal places. When you calculate the average, those illegal numbers must not be counted in.Input Specification:Each input file contains one test case. For each case, the first line gives a positive integer N (<=100). Then N numbers are given in the next line, separated by one space.Output Specification:For each illegal input number, print in a line "ERROR: X is not a legal number" where X is the input. Then finally print in a line the result: "The average of K numbers is Y" where K is the number of legal inputs and Y is their average, accurate to 2 decimalplaces. In case the average cannot be calculated, output "Undefined" instead of Y. In case K is only 1, output "The average of 1 number is Y" instead.Sample Input 1:
7
5 -3.2 aaa 9999 2.3.4 7.123 2.35
Sample Output 1:
ERROR: aaa is not a legal number
ERROR: 9999 is not a legal number
ERROR: 2.3.4 is not a legal number
ERROR: 7.123 is not a legal number
The average of 3 numbers is 1.38
Sample Input 2:
2
aaa -9999
Sample Output 2:
ERROR: aaa is not a legal number
ERROR: -9999 is not a legal number
The average of 0 numbers is Undefined
#include <iostream>
#include <string>
#include <vector>
#include <cstdlib>
using namespace std;
int main()
{
string s;
int n,cnt=0;
double avg=0;
cin>>n;
for(int i=0;i<n;i++){
cin>>s;
bool legal = true;
bool dot_cnt = 0;
for(int i=0;i<s.size();i++){
if(!(s[i]>= '0' && s[i] <= '9') && s[i] != '-' && s[i] != '.'){
4000

legal = false;
break;
}
if(s[i] == '.'){
if(s.size() - i > 3){
legal = false;
break;
}
dot_cnt++;
if(dot_cnt >= 2)
{
legal = false;
break;
}
}
}
if(legal == true){
double a = (double)strtod(s.c_str(),NULL);
if(a > 1000 || a<-1000){
cout<<"ERROR: "<<s<<" is not a legal number\n";
continue;
}
avg += a;
cnt++;
}
else
cout<<"ERROR: "<<s<<" is not a legal number\n";
}
if(cnt != 0){
if(cnt == 1)printf("The average of 1 number is %.2lf\n",avg/cnt);
else printf("The average of %d numbers is %.2lf\n",cnt,avg/cnt);
}
else cout<<"The average of 0 numbers is Undefined\n";
system("pause");
return 0;
}
用strtol直接简化步骤,又做了一遍这道题发现破绽还挺多的,首先题目里没有规定.xx 或 xx.是不是合法的,还有 3e1这样的科学计数法表示的小数是不是合法的。
而下面的这种方法忽略了上面的情况也能通过。
<pre name="code" class="cpp">#include <iostream>#include <string>#include <cstdlib>using namespace std;int main(){int n,cnt = 0;cin>>n;string num;double sum = 0.0;for(int i=0;i<n;i++){cin>>num;char * pos;double value = strtod(num.c_str(),&pos);bool ok = true;if(*pos != '\0')ok = false;if(value<-1000 || value >1000)ok = false;int lpos = num.find_last_of(".");if(lpos != string::npos) if(num.size() - lpos > 3)ok = false;if(ok){cnt++;sum += value;}elseprintf("ERROR: %s is not a legal number\n",num.c_str());}if(cnt != 0){if(cnt != 1)printf("The average of %d numbers is %.2lf\n",cnt,sum/cnt);else printf("The average of 1 number is %.2lf\n",sum);}else cout<<"The average of 0 numbers is Undefined\n";return 0;}

                                            
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  pat