您的位置:首页 > 其它

POJ1611——The Suspects 并查集基础

2016-03-14 21:10 399 查看
又一道并查集基础题

题目如下:

The Suspects

Time Limit: 1000MS Memory Limit: 20000K
Total Submissions: 30194 Accepted: 14684
Description

Severe acute respiratory syndrome (SARS), an atypical pneumonia of unknown aetiology, was recognized as a global threat in mid-March 2003. To minimize transmission to others, the best strategy is to separate the suspects from others. 

In the Not-Spreading-Your-Sickness University (NSYSU), there are many student groups. Students in the same group intercommunicate with each other frequently, and a student may join several groups. To prevent the possible transmissions of SARS, the NSYSU collects
the member lists of all student groups, and makes the following rule in their standard operation procedure (SOP). 

Once a member in a group is a suspect, all members in the group are suspects. 

However, they find that it is not easy to identify all the suspects when a student is recognized as a suspect. Your job is to write a program which finds all the suspects.
Input

The input file contains several cases. Each test case begins with two integers n and m in a line, where n is the number of students, and m is the number of groups. You may assume that 0 < n <= 30000 and 0 <= m <= 500. Every student is numbered by a unique integer
between 0 and n−1, and initially student 0 is recognized as a suspect in all the cases. This line is followed by m member lists of the groups, one line per group. Each line begins with an integer k by itself representing the number of members in the group.
Following the number of members, there are k integers representing the students in this group. All the integers in a line are separated by at least one space. 

A case with n = 0 and m = 0 indicates the end of the input, and need not be processed.
Output

For each case, output the number of suspects in one line.
Sample Input
100 4
2 1 2
5 10 13 11 12 14
2 0 1
2 99 2
200 2
1 5
5 1 2 3 4 5
1 0
0 0

Sample Output
4
1
1


题目大意:
有一群学生,分别属于不同队伍,若一个队伍中有一个人被列为怀疑对象,那整个队伍中的人都是怀疑对象,一个人可能属于很多队伍,求一共有多少个怀疑对象。
同样是并查集的基础题,就是查和0有着相同根节点的学生的个数。合并之后遍历一遍就行。easy。

#include <cstdio>
#include <algorithm>
#include <cstring>
#include <iostream>
#include <cmath>
#include <queue>
#include <ctype.h>
using namespace std;
#define INF 1000000000
typedef long long LL;
#define MAXN 30010

int par[MAXN];//父亲
int r[MAXN];//树的高度
//初始化n个元素
void init(int n)
{
for(int i=0;i<n;i++)
{
par[i]=i;
r[i]=0;
}
}
//查询数的根
int find(int x)
{
if(par[x]==x)
return x;
else
return par[x]=find(par[x]);
}
//合并x和y所属的集合
void unite(int x,int y){
x=find(x);
y=find(y);
if(x==y)
return;
if(r[x]<r[y])
par[x]=y;
else
par[y]=x;
if(r[x]==r[y])
r[x]++;
}

bool same(int x,int y)
{
return find(x)==find(y);
}

int main()
{
int n,m;
while(scanf("%d%d",&n,&m))
{
if(n==0&&m==0)
break;
init(n);
for(int i=0;i<m;i++)
{
int k,a,b;
scanf("%d",&k);
scanf("%d",&a);
for(int j=1;j<k;j++)
{
scanf("%d",&b);
unite(a,b);
}
}
int cnt=0;
for(int i=0;i<n;i++)
if(same(0,i))
cnt++;
printf("%d\n",cnt);
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: