您的位置:首页 > 产品设计 > UI/UE

POJ2524——Ubiquitous Religions 并查集基础

2016-03-14 20:56 344 查看
并查集的基础应用

题目如下:

Description

There are so many different religions in the world today that it is difficult to keep track of them all. You are interested in finding out how many different religions students in your university believe in. 

You know that there are n students in your university (0 < n <= 50000). It is infeasible for you to ask every student their religious beliefs. Furthermore, many students are not comfortable expressing their beliefs. One way to avoid these problems is to ask
m (0 <= m <= n(n-1)/2) pairs of students and ask them whether they believe in the same religion (e.g. they may know if they both attend the same church). From this data, you may not know what each person believes in, but you can get an idea of the upper bound
of how many different religions can be possibly represented on campus. You may assume that each student subscribes to at most one religion.
Input

The input consists of a number of cases. Each case starts with a line specifying the integers n and m. The next m lines each consists of two integers i and j, specifying that students i and j believe in the same religion. The students are numbered 1 to n. The
end of input is specified by a line in which n = m = 0.
Output

For each test case, print on a single line the case number (starting with 1) followed by the maximum number of different religions that the students in the university believe in.
Sample Input
10 9
1 2
1 3
1 4
1 5
1 6
1 7
1 8
1 9
1 10
10 4
2 3
4 5
4 8
5 8
0 0

Sample Output
Case 1: 1
Case 2: 7

Hint

Huge input, scanf is recommended.

分析:

题目大意很简单,有n个学生,给你m个信息,每条信息代表这两个人是信仰同一个宗教,问你最多有多少种不同的宗教。

相当于,信仰同一个宗教的学生属于同一个类,问共有多少类学生。既然是分类,用并查集的效率就很高了。遍历一遍看有多少个根节点就行。      虽然用数组记录好像也行?那样的复杂度应该是n2,貌似也能过。

代码如下

#include <stdio.h>
#include <algorithm>
#include <cstring>
#include <iostream>
#include <cmath>
#include <queue>
#include <ctype.h>
using namespace std;
#define INF 1000000000
typedef long long LL;
#define MAXN 50010

int par[MAXN];//父亲
int r[MAXN];//树的高度
//初始化n个元素
void init(int n)
{
for(int i=0;i<n;i++)
{
par[i]=i;
r[i]=0;
}
}
//查询数的根
int find(int x)
{
if(par[x]==x)
return x;
else
return par[x]=find(par[x]);
}
//合并x和y所属的集合
void unite(int x,int y){
x=find(x);
y=find(y);
if(x==y)
return;
if(r[x]<r[y])
par[x]=y;
else
par[y]=x;
if(r[x]==r[y])
r[x]++;
}

bool same(int x,int y)
{
return find(x)==find(y);
}
int main()
{
int n,m;
int t=1;
while(scanf("%d%d",&n,&m))
{
if(n==0&&m==0)
break;
init(n);
int cnt=0;
for(int i=0;i<m;i++)
{
int a,b;
scanf("%d%d",&a,&b);
unite(a-1,b-1);
}
for(int i=0;i<n;i++)
{
if(par[i]==i)
cnt++;
}
printf("Case %d: %d\n",t,cnt);
t++;
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: