您的位置:首页 > 其它

I'll play a trick on you

2016-03-14 20:36 429 查看


I'll play a trick on you

时间限制:3000 ms  |  内存限制:65535 KB
难度:1

描述Please look the picture carefully. Then I'll give you two integers and your task is output the third one.

Please never doubt the picture.



输入The first line is a number T(1<=T<=30), represents the number of case. The next T blocks follow each indicates a case.

Each case contains two integers A,B (1<=B<=A<=10^100)
输出For each case, output the number of case and the third integer.
样例输入
3
99 72
45 27
39 18


样例输出
27
18
21


来源2011 Alibaba Programming Contest
上传者
李文鑫

#include<stdio.h>

#include<string.h>

int main()

{
int t,i,j,sum1,sum2,sum,len1,len2;
scanf("%d",&t);
while(t--)
{
char a[101]={'\0'},b[101]={'\0'};
sum=0;
sum1=0;
sum2=0;
scanf("%s%s",a,b);
len1=strlen(a);
len2=strlen(b);
for(i=0;i<len1;++i)
sum1=sum1+(a[i]-'0');

for(j=0;j<len2;j++)
sum2=sum2+(b[j]-'0');

sum=sum1+sum2;
printf("%d\n",sum);
}
return 0;

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: