您的位置:首页 > 其它

hdu 3631 Shortest Path(Floyd)

2016-03-14 19:02 519 查看
题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=3631

Shortest Path

Time Limit: 3000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3962 Accepted Submission(s): 938

[align=left]Problem Description[/align]
When YY was a boy and LMY was a girl, they trained for NOI (National Olympiad in Informatics) in GD team. One day, GD team’s coach, Prof. GUO asked them to solve the following shortest-path problem.

There is a weighted directed multigraph G. And there are following two operations for the weighted directed multigraph:

(1) Mark a vertex in the graph.

(2) Find the shortest-path between two vertices only through marked vertices.

For it was the first time that LMY faced such a problem, she was very nervous. At this moment, YY decided to help LMY to analyze the shortest-path problem. With the help of YY, LMY solved the problem at once, admiring YY very much. Since then, when LMY meets
problems, she always calls YY to analyze the problems for her. Of course, YY is very glad to help LMY. Finally, it is known to us all, YY and LMY become programming lovers.

Could you also solve the shortest-path problem?

[align=left]Input[/align]
The input consists of multiple test cases. For each test case, the first line contains three integers N, M and Q, where N is the number of vertices in the given graph, N≤300; M is the number of arcs, M≤100000; and Q is the number
of operations, Q ≤100000. All vertices are number as 0, 1, 2, … , N - 1, respectively. Initially all vertices are unmarked. Each of the next M lines describes an arc by three integers (x, y, c): initial vertex (x), terminal vertex (y), and the weight of the
arc (c). (c > 0) Then each of the next Q lines describes an operation, where operation “0 x” represents that vertex x is marked, and operation “1 x y” finds the length of shortest-path between x and y only through marked vertices. There is a blank line between
two consecutive test cases.

End of input is indicated by a line containing N = M = Q = 0.

[align=left]Output[/align]
Start each test case with "Case #:" on a single line, where # is the case number starting from 1.

For operation “0 x”, if vertex x has been marked, output “ERROR! At point x”.

For operation “1 x y”, if vertex x or vertex y isn’t marked, output “ERROR! At path x to y”; if y isn’t reachable from x through marked vertices, output “No such path”; otherwise output the length of the shortest-path. The format is showed as sample output.

There is a blank line between two consecutive test cases.

[align=left]Sample Input[/align]

5 10 10
1 2 6335
0 4 5725
3 3 6963
4 0 8146
1 2 9962
1 0 1943
2 1 2392
4 2 154
2 2 7422
1 3 9896
0 1
0 3
0 2
0 4
0 4
0 1
1 3 3
1 1 1
0 3
0 4
0 0 0


[align=left]Sample Output[/align]

Case 1:
ERROR! At point 4
ERROR! At point 1
0
0
ERROR! At point 3
ERROR! At point 4


[align=left]Source[/align]
2010 Asia Regional Tianjin Site
—— Online Contest

代码例如以下:

#include <cstdio>
#include <cstring>
#define INF 0x3fffffff
#define MAXN 317
int dis[MAXN][MAXN];
int mark[MAXN];
int n;
int min(int a, int b)
{
return a < b ? a:b;
}
void init()
{
for(int i = 0; i < n; i++)
{
for(int j = 0; j < n; j++)
{
if(i == j)
dis[i][j] = 0;
else
dis[i][j] = INF;
}
}
}

void Floyd(int k)
{
for(int i = 0; i < n; i++)
{
for(int j = 0; j < n; j++)
{
dis[i][j] = min(dis[i][j],dis[i][k]+dis[k][j]);
}
}
}

int main()
{
int i, j;
int M, Q;
int a, b, w;
int cas = 0;
while(~scanf("%d%d%d",&n,&M,&Q))
{
if(n == 0 && M == 0 && Q == 0)
break;
if(cas != 0)
printf("\n");
init();
memset(mark,0,sizeof(mark));
for(i =  0; i < M; i++)
{
scanf("%d%d%d",&a,&b,&w);
if(w < dis[a][b])
{
dis[a][b] = w;
}
}
int op, x, y;
printf("Case %d:\n",++cas);
for(i = 0; i < Q; i++)
{
scanf("%d",&op);
if(op == 0)
{
scanf("%d",&x);
if(mark[x])
{
printf("ERROR! At point %d\n",x);
continue;
}
mark[x] = 1;
Floyd(x);
}
else if(op == 1)
{
scanf("%d%d",&x,&y);
if(!mark[x] || !mark[y])
{
printf("ERROR! At path %d to %d\n",x,y);
continue;
}
if(dis[x][y] >= INF)
printf("No such path\n");
else
printf("%d\n",dis[x][y]);
}
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: