您的位置:首页 > 其它

uva514(栈)

2016-03-14 16:49 375 查看
B -Rails
Time Limit:3000MS Memory Limit:0KB 64bit IO Format:%lld
& %llu
Submit Status

Description





There is a famous railway station in PopPush City. Country there is incredibly hilly. The station was built in last century. Unfortunately, funds were extremely limited that time. It was possible to establish
only a surface track. Moreover, it turned out that the station could be only a dead-end one (see picture) and due to lack of available space it could have only one track.



The local tradition is that every train arriving from the direction A continues in the direction B with coaches reorganized in some way. Assume that the train arriving from the direction A has

coaches
numbered in increasing order

. The chief for train reorganizations must know whether it is possible to
marshal coaches continuing in the direction B so that their order will be

. Help him and write
a program that decides whether it is possible to get the required order of coaches. You can assume that single coaches can be disconnected from the train before they enter the station and that they can move themselves until they are on the track in the direction
B. You can also suppose that at any time there can be located as many coaches as necessary in the station. But once a coach has entered the station it cannot return to the track in the direction A and also once it has left the station in the direction B it
cannot return back to the station.

Input

The input file consists of blocks of lines. Each block except the last describes one train and possibly more requirements for its reorganization. In the first line of the block there is the integer N described above. In each of the next lines of the
block there is a permutation of

The last line of the block contains just 0.
The last block consists of just one line containing 0.

Output

The output file contains the lines corresponding to the lines with permutations in the input file. A line of the output file contains Yes if it is possible to marshal the coaches in the order required on the corresponding line of the input file. Otherwise
it contains No. In addition, there is one empty line after the lines corresponding to one block of the input file. There is no line in the output file corresponding to the last ``null'' block of the input file.

Sample Input

5
1 2 3 4 5
5 4 1 2 3
0
6
6 5 4 3 2 1
0
0


Sample Output

Yes
No

Yes

输入:最先输入n(n为多组),表示有一到n组车厢。然后是多组输入,每组输入n个数代表重b的输出顺序。当输入为0时表示当前组输入结束。当输入n为0时表示输入文件结束。
输出:对于每一个序列,当能通过c在b处输出该数列是,输出Yes,否则则输出No.
解法:可以把c处看做一个栈,属于先进后出。有stl中的《stack》,用while(scanf()&&)来控制输入格式。
总结:注意对输入格式的控制
AC:

#include <iostream>
#include<stdio.h>
#include<queue>
#include<string.h>
#include<stack>
using namespace std;
#define ll long long int
#define maxn 1006
int n,target[maxn];
int main()
{
while(scanf("%d",&n)&&n)
{
while(scanf("%d",&target[1])&&target[1])
{
int a,b,f;
f=1;
a=1,b=1;
stack<int>s;
for(int i=2;i<=n;i++)
{

scanf("%d",&target[i]);
}
while(b<=n)
{

if(a==target[b]){a++;b++;}
else if(!s.empty()&&s.top()==target[b]) {s.pop();b++;}
else if(a<=n) s.push(a++);
else {f=0;break;}
}
printf("%s\n",f?"Yes":"No");
}
printf("\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: