您的位置:首页 > 其它

【hdu1969】Pie——二分

2016-03-13 23:48 399 查看
题目:


Pie

Time Limit: 5000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 7795 Accepted Submission(s): 2889



Problem Description

My birthday is coming up and traditionally I'm serving pie. Not just one pie, no, I have a number N of them, of various tastes and of various sizes. F of my friends are coming to my party and each of them gets a piece of pie. This should be one piece of one
pie, not several small pieces since that looks messy. This piece can be one whole pie though.

My friends are very annoying and if one of them gets a bigger piece than the others, they start complaining. Therefore all of them should get equally sized (but not necessarily equally shaped) pieces, even if this leads to some pie getting spoiled (which is
better than spoiling the party). Of course, I want a piece of pie for myself too, and that piece should also be of the same size.

What is the largest possible piece size all of us can get? All the pies are cylindrical in shape and they all have the same height 1, but the radii of the pies can be different.

Input

One line with a positive integer: the number of test cases. Then for each test case:

---One line with two integers N and F with 1 <= N, F <= 10 000: the number of pies and the number of friends.

---One line with N integers ri with 1 <= ri <= 10 000: the radii of the pies.

Output

For each test case, output one line with the largest possible volume V such that me and my friends can all get a pie piece of size V. The answer should be given as a floating point number with an absolute error of at most 10^(-3).

Sample Input

3
3 3
4 3 3
1 24
5
10 5
1 4 2 3 4 5 6 5 4 2


Sample Output

25.1327
3.1416
50.2655


Source

NWERC2006

描述:给N个等高圆柱体的半径,求把他们分给F+1个人的最大体积

题解:二分裸题,但是要注意精度,1e-6正好A,1e-8蜜汁WA

代码:

#include <cstdio>
#include <algorithm>
#include <cstring>
#include <cmath>
using namespace std;
const double eps = 1e-6;
const int maxn = 10005;
const double pi = acos(-1.0);
int r[maxn];
int main()
{
//freopen("input.txt", "r", stdin);
int T;
scanf("%d", &T);
while (T--)
{
int N, F;
scanf("%d%d", &N, &F);
for (int i = 0; i < N; i++)
{
scanf("%d", &r[i]);
}
sort(r, r + N);
double l = 0.0;
double r1 = pi*r[N - 1] * r[N - 1];
while (r1 - l > eps)
{
double mid = (l + r1) / 2;
int temp = 0;
for (int i = 0; i < N; i++)
temp += floor(pi*r[i] * r[i] / mid);
if (temp >= F + 1)
l = mid;
else
r1 = mid;
}
printf("%.4lf\n", l);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: