您的位置:首页 > 其它

Uva1585 Score (简单统计)

2016-03-13 20:25 295 查看
Score
Description

There is an objective test result such as ``OOXXOXXOOO". An `O' means a correct answer of a problem and an `X' means a wrong answer. The score of each problem of this test is calculated by itself and its just previous consecutive
`O's only when the answer is correct. For example, the score of the 10th problem is 3 that is obtained by itself and its two previous consecutive `O's.

Therefore, the score of ``OOXXOXXOOO" is 10 which is calculated by ``1+2+0+0+1+0+0+1+2+3".

You are to write a program calculating the scores of test results.

Input

Your program is to read from standard input. The input consists of
T test cases. The number of test cases T is given in the first line of the input. Each test case starts with a line containing a string composed by `O' and `
X' and the length of the string is more than 0 and less than 80. There is no spaces between `O' and `
X'.

Output

Your program is to write to standard output. Print exactly one line for each test case. The line is to contain the score of the test case.

The following shows sample input and output for five test cases.

Sample Input

5
OOXXOXXOOO
OOXXOOXXOO
OXOXOXOXOXOXOX
OOOOOOOOOO
OOOOXOOOOXOOOOX


Sample Output

10
9
7
55
30


原题链接:http://acm.hust.edu.cn/vjudge/problem/viewProblem.action?id=48771

<<算法竞赛入门经典>>习题3-1

题意:给出一个由O和X组成的串,统计得分,每个O的得分为目前连续出现的O的个数.

例如;OOXXOXXOOO的得分为:1+2+0+0+1+0+0+1+2+3

AC代码:

#include<cstdio>
#include<cstring>
using namespace std;
int main()
{
int n;
char a[100];
scanf("%d",&n);
getchar();
while(n--)
{
gets(a);
int len=strlen(a);
int sum=0,ans=0;
for(int i=0;i<len;i++)
{
if(a[i]=='O')
{
ans++;
sum+=ans;
}
else
ans=0;
}
printf("%d\n",sum);
}

return 0;

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: