您的位置:首页 > 其它

HDU 1097 a hard puzzle

2016-03-12 20:23 363 查看
[align=left]Problem Description[/align]
lcy gives a hard puzzle to feng5166,lwg,JGShining and Ignatius: gave a and b,how to know the a^b.everybody objects to this BT problem,so lcy makes the problem easier than begin.

this puzzle describes that: gave a and b,how to know the a^b's the last digit number.But everybody is too lazy to slove this problem,so they remit to you who is wise.

 

[align=left]Input[/align]
There are mutiple test cases. Each test cases consists of two numbers a and b(0<a,b<=2^30)

 

[align=left]Output[/align]
For each test case, you should output the a^b's last digit number.

 

[align=left]Sample Input[/align]

7 66
8 800

 

[align=left]Sample Output[/align]

9
6

简单来说,就是求前一个数的最后一个数的b次方的问题,很容易就看出来有规律,四个一循环,所以很容易就解决了。#include<stdio.h>
#include<math.h>
int main()
{
int a,b,a1,b1,sum;
while(scanf("%d%d",&a,&b)!=EOF)
{
a1=a%10;
b1=b%4;
if(b1==0){
sum=((int)pow(a1,4))%10;
printf("%d\n",sum);
}
else{
sum=((int)pow(a1,b1))%10;
printf("%d\n",sum);
}
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: