您的位置:首页 > 其它

Interview(位运算)

2016-03-12 20:11 295 查看
Interview
Crawling in process...
Crawling failed
Time Limit:1000MS    
Memory Limit:262144KB    
64bit IO Format:
%I64d & %I64u
Submit

Status
Practice
CodeForces 631A

Description

Blake is a CEO of a large company called "Blake Technologies". He loves his company very much and he thinks that his company should be the best. That is why every candidate needs to pass through the interview that consists of the following problem.

We define function f(x, l, r) as a bitwise OR of integers
xl, xl + 1, ..., xr, where
xi is the
i-th element of the array
x. You are given two arrays a and
b of length n. You need to determine the maximum value of sum
f(a, l, r) + f(b, l, r) among all possible
1 ≤ l ≤ r ≤ n.



Input

The first line of the input contains a single integer n (1 ≤ n ≤ 1000) — the length of the arrays.

The second line contains n integers
ai (0 ≤ ai ≤ 109).

The third line contains n integers
bi (0 ≤ bi ≤ 109).

Output

Print a single integer — the maximum value of sum f(a, l, r) + f(b, l, r) among all possible
1 ≤ l ≤ r ≤ n.

Sample Input

Input
5
1 2 4 3 2
2 3 3 12 1


Output
22


Input
10
13 2 7 11 8 4 9 8 5 1
5 7 18 9 2 3 0 11 8 6


Output
46


Sample Output

Hint

Bitwise OR of two non-negative integers a and
b is the number c = aORb,
such that each of its digits in binary notation is
1 if and only if at least one of
a or b have
1 in the corresponding position in binary notation. (或运算)


In the first sample, one of the optimal answers is l = 2 and
r = 4, because f(a, 2, 4) + f(b, 2, 4) = (2
OR 4 OR 3) + (3 OR 3 OR 12) = 7 + 15 = 22. Other ways to get maximum value is to choose
l = 1 and r = 4,
l = 1 and r = 5,
l = 2 and r = 4,
l = 2 and r = 5,
l = 3 and r = 4, or
l = 3 and r = 5.

In the second sample, the maximum value is obtained for
l = 1 and r = 9.

注;这题主要考查位运算:每一列中,得出最大一个数,这个数的每个二进制位上的1,在这一列数中都能找到一个或多个数在相同的二进制位置上的1与之对应。

之前想着循环除以2得到每个数的2进制位,不过感觉会超时,所以就百度别人的题解,发现直接用或运算很简便。

My   solution:

/*2016.3.12*/

#include<stdio.h>
int main()
{
int i,j,n,m,k;
int a[1100],b[1100];
while(scanf("%d",&n)==1)
{
for(i=1;i<=n;i++)
scanf("%d",&a[i]);
for(i=1;i<=n;i++)
scanf("%d",&b[i]);
for(i=2;i<=n;i++)
{
a[1]|=a[i];//与运算
b[1]|=b[i];
}
k=a[1]+b[1];
printf("%d\n",k);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: