您的位置:首页 > 其它

UVA - 10815 Andy's First Dictionary

2016-03-12 11:24 232 查看
Andy's First Dictionary

Andy, 8, has a dream - he wants to produce his very own dictionary. This is not an easy task for him, as the number of words that he knows is, well, not quite enough. Instead of thinking up all the words himself, he has a briliant idea. From his bookshelf
he would pick one of his favourite story books, from which he would copy out all the distinct words. By arranging the words in alphabetical order, he is done! Of course, it is a really time-consuming job, and this is where a computer program is helpful.

You are asked to write a program that lists all the different words in the input text. In this problem, a word is defined as a consecutive sequence of alphabets, in upper and/or lower case. Words with only one letter are also to be considered. Furthermore,
your program must be CaSe InSeNsItIvE. For example, words like "Apple", "apple" or "APPLE" must be considered the same.

Input

The input file is a text with no more than 5000 lines. An input line has at most 200 characters. Input is terminated by EOF.

Output

Your output should give a list of different words that appears in the input text, one in a line. The words should all be in lower case, sorted in alphabetical order. You can be sure that he number of distinct words in the text does not exceed 5000.

Sample Input

Adventures in Disneyland

Two blondes were going to Disneyland when they came to a fork in the
road. The sign read: "Disneyland Left."

So they went home.


Sample Output

a
adventures
blondes
came
disneyland
fork
going
home
in
left
read
road
sign
so
the
they
to
two
went
were
when


题目:给出一串单词,把所有单词改小写去重按字典序输出。

思路:set可以解决去重和排序问题。

set中每个元素最多只出现一次

set中的元素已经从小到大排序好

如何通过迭代器从小到大遍历所有元素

for (set<string>::iterator i = d.begin(); i != d.end(); i++)

cout << *i << endl;

代码:

#include<iostream>
#include<set>
#include<cstring>
#include<cstdio>
using namespace std;
set<string> a;

string c;
int main()
{
while(getline(cin,c))
{
for(int i=0;i<c.size();i++)
{
if(!isalpha(c[i])) continue;
string b;
while(isalpha(c[i]))
{

b+=tolower(c[i]);
i++;
}
a.insert(b);
}
}
set<string>::iterator it;
for(it=a.begin();it!=a.end();it++)
{

cout<<*it<<endl;
}

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: