您的位置:首页 > 其它

poj 1094 拓扑排序

2016-03-11 21:35 357 查看
Description

An ascending sorted sequence of distinct values is one in which some form of a less-than operator is used to order the elements from smallest to largest. For example, the sorted sequence A, B, C, D implies that A < B, B < C and C < D. in this problem, we will
give you a set of relations of the form A < B and ask you to determine whether a sorted order has been specified or not.
Input

Input consists of multiple problem instances. Each instance starts with a line containing two positive integers n and m. the first value indicated the number of objects to sort, where 2 <= n <= 26. The objects to be sorted will be the first n characters of
the uppercase alphabet. The second value m indicates the number of relations of the form A < B which will be given in this problem instance. Next will be m lines, each containing one such relation consisting of three characters: an uppercase letter, the character
"<" and a second uppercase letter. No letter will be outside the range of the first n letters of the alphabet. Values of n = m = 0 indicate end of input.
Output

For each problem instance, output consists of one line. This line should be one of the following three: 

Sorted sequence determined after xxx relations: yyy...y. 

Sorted sequence cannot be determined. 

Inconsistency found after xxx relations. 

where xxx is the number of relations processed at the time either a sorted sequence is determined or an inconsistency is found, whichever comes first, and yyy...y is the sorted, ascending sequence. 

Sample Input
4 6
A<B
A<C
B<C
C<D
B<D
A<B
3 2
A<B
B<A
26 1
A<Z
0 0

Sample Output
Sorted sequence determined after 4 relations: ABCD.
Inconsistency found after 2 relations.
Sorted sequence cannot be determined.


解题思路:

本题序列范围较小只有26个,而且输出要求路径的编号,所以每次添加路径都进行一次拓扑排序。

这道题wa了很多次,之前没有想到序列无序后可能会产生环,所以判断序列无序之后就直接跳出了,这里要注意。

#include<iostream>
#include<stdio.h>
#include<math.h>
#include<string.h>
#include<vector>
#include<queue>
#include<map>
#include<stack>
#include<queue>
#include<algorithm>
using namespace std;
int min(int a,int b)
{
if(a<b)return a;
else return b;
}
int max(int a,int b)
{
if(a>b)return a;
else return b;
}
int n,m;
int in[30],lines[30];
int maps[30][30];
int topu()
{
int vis[30],flag=3;
for(int i=0;i<n;i++)
vis[i]=in[i];
for(int pos=0;pos<n;pos++)
{
int num=0,x;
for(int i=0;i<n;i++)
if(vis[i]==0)
{
num++;
x=i;
}
if(num==0)return 1;//有环
if(num>1)flag=2;//不确定<span style="color:#ff0000;">(注意)</span>
//if(num==1)
//{
vis[x]=-1;
lines[pos]=x+'A';
for(int i=0;i<n;i++)
if(maps[x][i])
vis[i]--;
//}
}
return flag;//确定序列
}
int main()
{
//freopen("in.txt","r",stdin);
//freopen("out.txt","w",stdout);
while(scanf("%d%d",&n,&m)!=EOF)
{
if(n==0&&m==0)break;
memset(maps,0,sizeof(maps));
memset(in,0,sizeof(in));
memset(lines,0,sizeof(lines));
int flag1=0;
for(int j=0;j<m;j++)
{
char c[5];
scanf("%s",c);
if(flag1==1)
continue;
if(maps[c[0]-'A'][c[2]-'A']==0)
{
maps[c[0]-'A'][c[2]-'A']=1;
in[c[2]-'A']++;
}
int flag=topu();
if(flag==1)
{
printf("Inconsistency found after %d relations.\n",j+1);
flag1=1;
}
if(flag==3)
{
printf("Sorted sequence determined after %d relations: ",j+1);
for(int k=0;k<n;k++)
printf("%c",lines[k]);
printf(".\n");
flag1=1;
}
}
if(flag1==0)
printf("Sorted sequence cannot be determined.\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: