您的位置:首页 > 其它

HDU 4673 Theme Section

2016-03-11 19:07 399 查看

Theme Section

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
[align=left]Problem Description[/align]
It's time for music! A lot of popular musicians are invited to join us in the music festival. Each of them will play one of their representative songs. To make the programs more interesting and challenging, the hosts are going to add some constraints to the rhythm of the songs, i.e., each song is required to have a 'theme section'. The theme section shall be played at the beginning, the middle, and the end of each song. More specifically, given a theme section E, the song will be in the format of 'EAEBE', where section A and section B could have arbitrary number of notes. Note that there are 26 types of notes, denoted by lower case letters 'a' - 'z'.
To get well prepared for the festival, the hosts want to know the maximum possible length of the theme section of each song. Can you help us?

 

[align=left]Input[/align]
The integer N in the first line denotes the total number of songs in the festival. Each of the following N lines consists of one string, indicating the notes of the i-th (1 <= i <= N) song. The length of the string will not exceed 10^6.

 

[align=left]Output[/align]
There will be N lines in the output, where the i-th line denotes the maximum possible length of the theme section of the i-th song.

 

[align=left]Sample Input[/align]

5
xy
abc
aaa
aaaaba
aaxoaaaaa


[align=left]Sample Output[/align]

0
0
1
1
2

题意是保证前缀后缀相同的情况下,求这个前缀或者后缀长度最多能多长并保证前缀后缀中间还有一个这样的与前缀后缀相同的字符串。

一开始理解错了,以为是分成三段都是前缀相同。结果一直做不出来,看了一眼别人的做法,发现自己理解错了。

这个一想就知道用KMP会很简单,看还有人用EKMP,索性我也学着写了一下。

得到next数组后直接遍历找最大值,但是这个最大值需要满足的条件就是对应的i小于i且小于next[i]且小于(len - i) / 2,前两个约束条件很简单就能想明白,而最后一个约束条件是为了防止中间那段和后缀重叠所做的。这样最后我们只需要对后三分之一直接遍历一遍找到所有next[i] + i = len的点,如果该点对应的next[i]小的话,需要更新最大值。

代码如下:

/*************************************************************************
> File Name: Theme_Section.cpp
> Author: ZhangHaoRan
> Mail: chilumanxi@gmail.com
> Created Time: 2016年03月11日 星期五 17时47分33秒
************************************************************************/

#include<iostream>
#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<string>
#include<vector>
#include<set>
#include<map>
#include<queue>
#include<list>
#include<algorithm>

using namespace std;

char str[1000010];
int nexti[1000010];
int len;

void pre_EKMP(){
nexti[0] = len;
int j = 0;
while(j + 1 < len && str[j] == str[j + 1])
j ++;
nexti[1] = j;
int k = 1;
for(int i = 2; i < len; i ++){
int p = nexti[k] + k - 1;
int l = nexti[i - k];
if(i + l < p + 1)
nexti[i] = l;
else{
j = max(0, p - i + 1);
while(i + j < len && str[i + j] == str[j])
j ++;
nexti[i] = j;
k = i;
}
}
}

int T;

int main(void){
cin >> T;
while(T --){
cin >> str;
len = strlen(str);
pre_EKMP();
int ans = 0;
int maxlen = 0;
for(int i = 1; i < len; i ++){
maxlen = min(i, nexti[i]);
maxlen = min(maxlen, (len - i) / 2);
ans = max(ans, maxlen);
}
int res = 0;
for(int i = len - len / 3; i < len ; i ++){
if(nexti[i] + i != len)
continue;
if(ans >= nexti[i]){
res = nexti[i];
break;
}
}
cout << res << endl;
}
return 0;
}

 

查看原文:http://chilumanxi.org/2016/03/11/hdu-4673-theme-section/
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: