您的位置:首页 > 其它

PAT (Advanced Level) Practise 1048 Find Coins (25)

2016-03-11 18:19 375 查看


1048. Find Coins (25)

时间限制

50 ms

内存限制

65536 kB

代码长度限制

16000 B

判题程序

Standard

作者

CHEN, Yue

Eva loves to collect coins from all over the universe, including some other planets like Mars. One day she visited a universal shopping mall which could accept all kinds of coins as payments. However, there was a special requirement of the payment: for each
bill, she could only use exactly two coins to pay the exact amount. Since she has as many as 105 coins with her, she definitely needs your help. You are supposed to tell her, for any given amount of money, whether or not she
can find two coins to pay for it.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive numbers: N (<=105, the total number of coins) and M(<=103, the amount of money Eva has to pay). The second
line contains N face values of the coins, which are all positive numbers no more than 500. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the two face values V1 and V2 (separated by a space) such that V1 + V2 = M and V1 <=
V2. If such a solution is not unique, output the one with the smallest V1. If there is no solution, output "No Solution" instead.
Sample Input 1:
8 15
1 2 8 7 2 4 11 15

Sample Output 1:
4 11

Sample Input 2:
7 14
1 8 7 2 4 11 15

Sample Output 2:

No Solution

简单题,判断有没有两个数和是m,输出最小的组合

#include<map>
#include<queue>
#include<stack>
#include<cstdio>
#include<string>
#include<vector>
#include<cstring>
#include<iostream>
#include<algorithm>
#include<functional>
using namespace std;
typedef long long LL;
const int maxn = 1e4 + 10;
int n, m, f[maxn], x;

int main()
{
scanf("%d%d", &n, &m);
while (n--)
{
scanf("%d", &x);
f[x]++;
}
for (int i = 1; i + i <= m; i++)
{
if (i + i == m)
{
if (f[i] >= 2)
{
printf("%d %d\n", i, m - i);
return 0;
}
}
else if (f[i] && f[m - i])
{
printf("%d %d\n", i, m - i);
return 0;
}
}
printf("No Solution\n");
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  PAT