您的位置:首页 > 产品设计 > UI/UE

A1101. Quick Sort (25)

2016-03-11 17:39 411 查看
题目描述:

There is a classical process named partition in the famous quick sort algorithm. In this process we typically choose one element as the pivot. Then the elements less than the pivot are moved to its left and those larger
than the pivot to its right. Given N distinct positive integers after a run of partition, could you tell how many elements could be the selected pivot for this partition?

For example, given N = 5 and the numbers 1, 3, 2, 4, and 5. We have:

1 could be the pivot since there is no element to its left and all the elements to its right are larger than it;
3 must not be the pivot since although all the elements to its left are smaller, the number 2 to its right is less than it as well;
2 must not be the pivot since although all the elements to its right are larger, the number 3 to its left is larger than it as well;
and for the similar reason, 4 and 5 could also be the pivot.

Hence in total there are 3 pivot candidates.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (<= 105). Then the next line contains N distinct positive integers no larger than 109. The numbers in a line
are separated by spaces.

Output Specification:

For each test case, output in the first line the number of pivot candidates. Then in the next line print these candidates in increasing order. There must be exactly 1 space between two adjacent numbers, and no extra space at
the end of each line.

Sample Input:
5
1 3 2 4 5

Sample Output:
3
1 4 5


题意解析:

给出一个数组,找出下标为index的值的集合,该集合中的值满足比index之前的大,比index之后的小。集合要从小到大排序。

解题思路

使用两个for循环会超时。

使用两个bool类型的数组flagL和flagR分别表示当前index是否满足比index之前的大,比index之后的小。

以判断是否满足比index之前的大为例。

用Max记录index之前最大的值,当a[index]大于Max,更新Max,并标记flagR[index]=true。

判断是否满足比index之后的小如法炮制。

当flagL[index]和flagR[index]都为true时,即位题意要求的povit。

注意点:当没有找到povit时,需要回车两次。

参考代码

<span style="font-size:14px;">#include <cstdio>
#include <algorithm>

using namespace std;

const int maxn = 100010;

int a[maxn],n,result[maxn]={0},len=0;
bool flagL[maxn] = {false},flagR[maxn] = {false};
int Min = 1000000000,Max = -1;

int main()
{
scanf("%d",&n);
for(int i =0;i<n;i++)
{
scanf("%d",&a[i]);
}
for(int i=0;i<n;i++)
{
if(a[i] > Max)
{
Max = a[i];
flagL[i] = true;
}
}
for(int i=n-1;i>=0;i--)
{
if(a[i] < Min)
{
Min = a[i];
flagR[i] = true;
}
}
for(int i=0;i<n;i++)
{
if(flagL[i] && flagR[i])
{
result[len++] = a[i];
}
}
sort(result,result+len);
printf("%d\n",len);
for(int i=0;i<len;i++)
{
if(i == 0)
printf("%d",result[i]);
else
printf(" %d",result[i]);
}
printf("\n");
return 0;
}</span>
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  pat 算法