您的位置:首页 > 其它

HDU 1.3.5 shǎ崽 OrOrOrOrz

2016-03-10 18:10 337 查看

shǎ崽 OrOrOrOrz

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3988 Accepted Submission(s): 1236
 
[align=left]Problem Description[/align]
Acmer in HDU-ACM team are ambitious, especially shǎ崽, he can spend time in Internet bar doing problems overnight. So many girls want to meet and Orz him. But Orz him is not that easy.You must solve this problem first.

The problem is :

Give you a sequence of distinct integers, choose numbers as following : first choose the biggest, then smallest, then second biggest, second smallest etc. Until all the numbers was chosen . 

For example, give you 1 2 3 4 5, you should output 5 1 4 2 3

 
[align=left]Input[/align]
There are multiple test cases, each case begins with one integer N(1 <= N <= 10000), following N distinct integers.
 
[align=left]Output[/align]
Output a sequence of distinct integers described above.
 
[align=left]Sample Input[/align]

5
1 2 3 4 5


 
[align=left]Sample Output[/align]

5 1 4 2 3


 
菜鸟级的原创代码,已AC。若有可提高之处欢迎指导
//#define LOCAL
#include<stdio.h>
#include<string>
#include<algorithm>
using std::sort;
bool cmp(int a, int b)
{
return a>b;
}

int main()
{
#ifdef LOCAL
freopen("H://dataIn.txt", "r", stdin);
freopen("H://dataOut.txt", "w", stdout);
#endif
int a[10000];
int n;
while(scanf("%d", &n)==1)
{
memset(a, 0, sizeof(a));
for (int i = 0; i<n; i++)
scanf("%d",&a[i]);
sort(a, a + n, cmp);
for (int i = 0; i < n / 2-1; i++)
{
printf("%d ", a[i]);
printf("%d ", a[n-i-1]);
}
if (double(n) / 2 == double(n / 2))
{
printf("%d ", a[n/2-1]);
printf("%d\n", a[n/2]);
}
else
{
printf("%d ", a[n / 2 - 1]);
printf("%d ", a[n / 2 + 1]);
printf("%d\n", a[n / 2]);
}
}
return 0;

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  ACM HDU