您的位置:首页 > 其它

HDU 1.3.2 Tian Ji -- The Horse Racing

2016-03-10 18:08 239 查看

Tian Ji -- The Horse Racing

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 4215 Accepted Submission(s): 1021
 
[align=left]Problem Description[/align]
Here is a famous story in Chinese history.

"That was about 2300 years ago. General Tian Ji was a high official in the country Qi. He likes to play horse racing with the king and others."

"Both of Tian and the king have three horses in different classes, namely, regular, plus, and super. The rule is to have three rounds in a match; each of the horses must be used in one round. The winner of a single round takes two hundred silver dollars from
the loser."

"Being the most powerful man in the country, the king has so nice horses that in each class his horse is better than Tian's. As a result, each time the king takes six hundred silver dollars from Tian."

"Tian Ji was not happy about that, until he met Sun Bin, one of the most famous generals in Chinese history. Using a little trick due to Sun, Tian Ji brought home two hundred silver dollars and such a grace in the next match."

"It was a rather simple trick. Using his regular class horse race against the super class from the king, they will certainly lose that round. But then his plus beat the king's regular, and his super beat the king's plus. What a simple trick. And how do you
think of Tian Ji, the high ranked official in China?"



Were Tian Ji lives in nowadays, he will certainly laugh at himself. Even more, were he sitting in the ACM contest right now, he may discover that the horse racing problem can be simply viewed as finding the maximum matching in a bipartite graph. Draw Tian's
horses on one side, and the king's horses on the other. Whenever one of Tian's horses can beat one from the king, we draw an edge between them, meaning we wish to establish this pair. Then, the problem of winning as many rounds as possible is just to find
the maximum matching in this graph. If there are ties, the problem becomes more complicated, he needs to assign weights 0, 1, or -1 to all the possible edges, and find a maximum weighted perfect matching...

However, the horse racing problem is a very special case of bipartite matching. The graph is decided by the speed of the horses --- a vertex of higher speed always beat a vertex of lower speed. In this case, the weighted bipartite matching algorithm is a too
advanced tool to deal with the problem.

In this problem, you are asked to write a program to solve this special case of matching problem.

 
[align=left]Input[/align]
The input consists of up to 50 test cases. Each case starts with a positive integer n (n <= 1000) on the first line, which is the number of horses on each side. The next n integers on the second line are the speeds of Tian’s horses.
Then the next n integers on the third line are the speeds of the king’s horses. The input ends with a line that has a single 0 after the last test case.

 
[align=left]Output[/align]
For each input case, output a line containing a single number, which is the maximum money Tian Ji will get, in silver dollars.

 
[align=left]Sample Input[/align]

3
92 83 71
95 87 74
2
20 20
20 20
2
20 19
22 18
0


 
[align=left]Sample Output[/align]

200
0
0


 
正确方法之一:

贪心法求解。

如果田忌最强的马能赛过国王最强的马,那么赛一场。

如果田忌最弱的马能赛过国王最弱的马,那么赛一场。

否则,用田忌最弱的马和国王最强的马赛一把。
#include<stdio.h>
#include<iostream>
#include<algorithm>
using namespace std;
int a[3000],b[3000];
int cmp(int a,int b)
{
return a>b;
}
int main()
{
int i,n,j,sum,k,f,ji;
while( scanf("%d",&n) && n!=0 )
{
for(i=0;i<n;i++)
scanf("%d",&a[i]);
for(i=0;i<n;i++)
scanf("%d",&b[i]);
sort(a,a+n,cmp);
sort(b,b+n,cmp);
ji=0;    //   记录 king  比赛用的马  循环跳出的判定条件
i=j=sum=0;
k=n-1;
f=n-1;
while(1)
{
if(ji==n)   break;   //   king  的马全部比完后跳出
if(b[j]>a[i]) {   sum-=200;j++;k--;ji++; continue;}  //如果king的比tian的快马快 用tian的慢马对king的快马
if(b[j]==a[i]){                                       //如果相等
if(b[f]<a[k]){f--;k--;sum+=200;ji++;continue;} //看两人的慢马 tian的慢马比king的慢马快则比
if(b[j]>a[k]){sum-=200;k--;j++;ji++;}
else {k--;j++;ji++;}
continue;
}
if(b[j]<a[i]){sum+=200;j++;i++;ji++;continue;}  //如果tian的比king的快马快 直接比
}
printf("%d\n",sum);
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  ACM HDU