您的位置:首页 > 其它

PAT (Basic Level)1043. 输出PATest

2016-03-10 15:15 465 查看
https://www.patest.cn/contests/pat-b-practise/1043

题目描述:

给定一个长度不超过10000的、仅由英文字母构成的字符串。请将字符重新调整顺序,按“PATestPATest....”这样的顺序输出,并忽略其它字符。当然,六种字符的个数不一定是一样多的,若某种字符已经输出完,则余下的字符仍按PATest的顺序打印,直到所有字符都被输出。

输入格式:

输入在一行中给出一个长度不超过10000的、仅由英文字母构成的非空字符串。

输出格式:

在一行中按题目要求输出排序后的字符串。题目保证输出非空。
输入样例:
redlesPayBestPATTopTeePHPereatitAPPT

输出样例:
PATestPATestPTetPTePePee

这一系列的index函数真是好用啊。

#include <iostream>
#include <string>
#include <algorithm>
#include <cmath>
#include <iomanip>
#include <ctype.h>
using namespace std;

int index(char ch)
{
if ( ch <= 'z' && ch >= 'a') return ch-'a';
else return 26 + ch-'A';
}

int main()
{
int c[52] = {0}, i = 0;
string s = "";
getline( cin , s );

for ( i = 0 ; i < s.length() ; i++ )
c[index(s[i])] ++ ;

int Pi = c[index('P')];
int Ai = c[index('A')];
int Ti = c[index('T')];
int ei = c[index('e')];
int si = c[index('s')];
int ti = c[index('t')];
while ( Pi + Ai + Ti + ei + si + ti > 0)
{
if ( Pi > 0) cout << 'P', Pi--;
if ( Ai > 0) cout << 'A', Ai--;
if ( Ti > 0) cout << 'T', Ti--;
if ( ei > 0) cout << 'e', ei--;
if ( si > 0) cout << 's', si--;
if ( ti > 0) cout << 't', ti--;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: