您的位置:首页 > 其它

Fire Game

2016-03-09 22:56 381 查看
Description

Fat brother and Maze are playing a kind of special (hentai) game on an N*M board (N rows, M columns). At the beginning, each grid of this board is consisting of grass or just empty and then they start to fire all the grass. Firstly they choose two grids which are consisting of grass and set fire. As we all know, the fire can spread among the grass. If the grid (x, y) is firing at time t, the grid which is adjacent to this grid will fire at time t+1 which refers to the grid (x+1, y), (x-1, y), (x, y+1), (x, y-1). This process ends when no new grid get fire. If then all the grid which are consisting of grass is get fired, Fat brother and Maze will stand in the middle of the grid and playing a MORE special (hentai) game. (Maybe it’s the OOXX game which decrypted in the last problem, who knows.)

You can assume that the grass in the board would never burn out and the empty grid would never get fire.

Note that the two grids they choose can be the same.

Input

The first line of the date is an integer T, which is the number of the text cases.

Then T cases follow, each case contains two integers N and M indicate the size of the board. Then goes N line, each line with M character shows the board. “#” Indicates the grass. You can assume that there is at least one grid which is consisting of grass in the board.

1 <= T <=100, 1 <= n <=10, 1 <= m <=10

Output

For each case, output the case number first, if they can play the MORE special (hentai) game (fire all the grass), output the minimal time they need to wait after they set fire, otherwise just output -1. See the sample input and output for more details.

Sample Input

4 3 3
.#.
###
.#.
3 3
.#.
#.#
.#.
3 3
...
#.#
...
3 3
###
..#
#.#

Sample Output

Case 1: 1
Case 2: -1
Case 3: 0
Case 4: 2

#include<cstdio>
#include<cstring>
#include<queue>
#include<vector>
using namespace std;
struct Node{
int x,y,step;
Node(){}
Node(int y,int x,int s)
{
this->y=y;
this->x=x;
this->step=s;
}
};
typedef pair<int,int> P;
const int MAXN=15;
int vis[MAXN][MAXN];
char mp[MAXN][MAXN];
int n,m;
vector<P> vec;
int dy[4]={0,1,0,-1};
int dx[4]={1,0,-1,0};
int bfs(P a,P b)
{
memset(vis,0,sizeof(vis));
queue<Node> que;
que.push(Node(a.first,a.second,0));
que.push(Node(b.first,b.second,0));
vis[a.first][a.second]=1;
vis[b.first][b.second]=1;
int res=0;
while(!que.empty())
{
Node now=que.front();que.pop();
res=max(now.step,res);
for(int i=0;i<4;i++)
{
int ny=dy[i]+now.y;
int nx=dx[i]+now.x;
if(0<=ny&&ny<n&&0<=nx&&nx<m&&!vis[ny][nx]&&mp[ny][nx]=='#')
{
vis[ny][nx]=1;
que.push(Node(ny,nx,now.step+1));
}
}
}
return res;
}
int main()
{
int T;
scanf("%d",&T);
for(int cas=1;cas<=T;cas++)
{
scanf("%d%d",&n,&m);
vec.clear();
for(int i=0;i<n;i++)
{
scanf("%*c");
for(int j=0;j<m;j++)
{
scanf("%c",&mp[i][j]);
if(mp[i][j]=='#')
vec.push_back(P(i,j));
}
}
int mn=0x3fffffff;
for(int i=0;i<vec.size();i++)
for(int j=i;j<vec.size();j++)
{
bool flag=true;
int res=bfs(vec[i],vec[j]);
for(int x=0;x<n;x++)
{
for(int y=0;y<m;y++)
{
if(mp[x][y]=='#'&&vis[x][y]==0)
{
flag=false;
break;
}
}
if(!flag)
break;
}
if(flag)
mn=min(mn,res);
}
if(mn==0x3fffffff)
printf("Case %d: -1\n",cas);
else
printf("Case %d: %d\n",cas,mn);

}

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: