您的位置:首页 > 其它

1043. Is It a Binary Search Tree (25)

2016-03-09 22:17 267 查看


1043. Is It a Binary Search Tree (25)

时间限制

400 ms

内存限制

65536 kB

代码长度限制

16000 B

判题程序

Standard

作者

CHEN, Yue

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

The left subtree of a node contains only nodes with keys less than the node's key.

The right subtree of a node contains only nodes with keys greater than or equal to the node's key.

Both the left and right subtrees must also be binary search trees.

If we swap the left and right subtrees of every node, then the resulting tree is called the Mirror Image of a BST.

Now given a sequence of integer keys, you are supposed to tell if it is the preorder traversal sequence of a BST or the mirror image of a BST.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (<=1000). Then N integer keys are given in the next line. All the numbers in a line are separated by a space.

Output Specification:

For each test case, first print in a line "YES" if the sequence is the preorder traversal sequence of a BST or the mirror image of a BST, or "NO" if not. Then if the answer is "YES", print in the next line the postorder traversal sequence of that tree. All
the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.
Sample Input 1:
7
8 6 5 7 10 8 11

Sample Output 1:
YES
5 7 6 8 11 10 8

Sample Input 2:
7
8 10 11 8 6 7 5

Sample Output 2:
YES
11 8 10 7 5 6 8

Sample Input 3:
7
8 6 8 5 10 9 11

Sample Output 3:
NO

建立二叉树后,使用先序遍历确定是否有误,无误的时候使用后续输出。
#include <iostream>
#include <vector>
using namespace std;
typedef struct Tree{
int key;
Tree *l;
Tree *r;
}Tree;
int pre[1001];
vector<int> pos;
vector<int> pre1;
void insert_tree(Tree *&root,int num);
void insert_mirror_tree(Tree *&root,int num);
void post_traversal(Tree *root);
void pre_traversal(Tree *root);
int main()
{
int n,flag=true;
cin >>n;
for(int i=0;i<n;i++)
cin >>pre[i];
//建树
Tree *root=NULL;
if(pre[1]<pre[0])
for(int i=0;i<n;i++)
insert_tree(root,pre[i]);
else
for(int i=0;i<n;i++)
insert_mirror_tree(root,pre[i]);
//使用先序遍历确定是否有误
pre_traversal(root);
vector<int>::iterator iter=pre1.begin();
int i=0;
for(;iter!=pre1.end();iter++)
if(*iter!=pre[i])
{
flag=false;
break;
}
else
{
i++;
}
//无误的时候,进行后续遍历,并将结果输出
if(flag)
{
cout <<"YES"<<endl;
post_traversal(root);
vector<int>::iterator iter=pos.begin();
cout <<*iter;
iter++;
for(;iter!=pos.end();iter++)
cout <<" " <<*iter;
}
//有误的时候,输出NO else
cout <<"NO";
cout <<endl;
return 0;
}
void insert_tree(Tree *&root,int num)//注意第一个参数的类型,写成Tree *root,是不能得到正确结果的。
{
if(root==NULL)
{
root=new Tree[1];
root->key=num;
root->l=NULL;
root->r=NULL;
return;
}
if(num<root->key)
insert_tree(root->l,num);
else
insert_tree(root->r,num);
}
void insert_mirror_tree(Tree *&root,int num)
{
if(root==NULL)
{
root=new Tree[1];
root->key=num;
root->l=NULL;
root->r=NULL;
return;
}
if(num>=root->key)
insert_mirror_tree(root->l,num);
else
insert_mirror_tree(root->r,num);
}
void post_traversal(Tree *root)
{
int tmp;
if(root==NULL)
return;
tmp=root->key;
post_traversal(root->l);
post_traversal(root->r);
int num;
num=pos.size();
pos.push_back(tmp);
num=pos.size();
return;
}
void pre_traversal(Tree *root)
{
int tmp;
if(root==NULL)
return;
tmp=root->key;
pre1.push_back(tmp);
pre_traversal(root->l);
pre_traversal(root->r);
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: