您的位置:首页 > 其它

杭电5615 Jam's math problem

2016-03-09 20:26 381 查看


Jam's math problem

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)

Total Submission(s): 821    Accepted Submission(s): 390


Problem Description

Jam has a math problem. He just learned factorization.

He is trying to factorize ax2+bx+c into
the form of pqx2+(qk+mp)x+km=(px+k)(qx+m).

He could only solve the problem in which p,q,m,k are positive numbers.

Please help him determine whether the expression could be factorized with p,q,m,k being postive.

 

Input

The first line is a number T,
means there are T(1≤T≤100) cases 

Each case has one line,the line has 3 numbers a,b,c(1≤a,b,c≤100000000)

 

Output

You should output the "YES" or "NO".

 

Sample Input

2
1 6 5
1 6 4

 

Sample Output

YES
NO

Hint
The first case turn $x^2+6*x+5$ into $(x+1)(x+5)$

 

Source

BestCoder Round #70

 
果不其然的A了,来来来,让我先装一波,抱紧我,我要起飞了,什么?你不懂一元二次方程的解?什么,你没有听说过十字交叉法?让赵大师教教你,对于a*x*x+b*x+c这个一元二次方程,如果解存在那么解的公式为

一元二次方程的求根公式导出过程如下:






 
(为了配方,两边各加
 

 









 
(化简得)。
那么对于方程(p*x-k)*(q*x-m)它的解为k/p和m/q,那么问题就来了,如果两个方程的解一样,是不是就可以说明两个方程一样?因为题目要求p,q,m,k,为整数,首先a,b,c为整数,那么2*a肯定为整数,-b也是整数,只要根号德尔塔为整数就满足了,不过得先判断德尔塔大于0 ,小于0就是没有解,而对于(p*x-k)*(q*x-m)肯定有解,所以德尔塔必定大于0,所以可得到代码:
#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<math.h>
using namespace std;
__int64 i,j,k,l,m,n,x,y,z;
int main()
{
scanf("%I64d",&l);
while(l--)
{
scanf("%I64d%I64d%I64d",&x,&y,&z);
m=y*y-4*x*z;
n=sqrt(m);
if(m<0)
{
printf("NO\n");
continue;
}
if(n*n==m)//德尔塔开方后为整数
printf("YES\n");
else
printf("NO\n");
}
}


k
ax2+bx+c
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  数学题 简单题