您的位置:首页 > 其它

1002. A+B for Polynomials (25)

2016-03-08 21:27 337 查看
This time, you are supposed to find A+B where A and B are two polynomials.

Input

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial: K N1 aN1 N2 aN2 ... NK aNK, where
K is the number of nonzero terms in the polynomial, Ni and aNi (i=1, 2, ..., K) are the exponents and coefficients, respectively. It is given that 1 <= K <= 10,0 <= NK < ... < N2 < N1 <=1000.

Output

For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.
Sample Input
2 1 2.4 0 3.2
2 2 1.5 1 0.5

Sample Output
3 2 1.5 1 2.9 0 3.2

#include<iostream>
#include<stdio.h>
#include<cmath>
using namespace std;
int main(){
float num[2002],coe;
int i,k,max=0,count=0;
int exp;
for(i=0;i<2002;i++) num[i]=0.0;

for(i=0;i<2;i++){
cin>>k;
while(k){
cin>>exp>>coe;
num[exp]+=coe;
if(exp>max) max=exp;
k--;
}
}
for(i=max;i>=0;i--){
if(num[i]!=0) ++count;
}
cout<<count;
for(i=max;i>=0;i--){
if(num[i]!=0) {cout<<' '<<i<<' ';printf("%.1f",num[i]);}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: