您的位置:首页 > 其它

1009. Product of Polynomials (25)

2016-03-08 17:34 519 查看
This time, you are supposed to find A*B where A and B are two polynomials.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial: K N1 aN1 N2 aN2 ... NK aNK, where
K is the number of nonzero terms in the polynomial, Ni and aNi (i=1, 2, ..., K) are the exponents and coefficients, respectively. It is given that 1 <= K <= 10, 0 <= NK < ... < N2 < N1 <=1000.

Output Specification:

For each test case you should output the product of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate up to 1 decimal place.
Sample Input
2 1 2.4 0 3.2
2 2 1.5 1 0.5

Sample Output
3 3 3.6 2 6.0 1 1.6

#include<iostream>
#include<stdio.h>
using namespace std;
int main(){
float num1[1001],num2[1001];
float rest[2001];
int i,j,n;
int count=0;
for(i=0;i<2001;++i){
rest[i]=0.0;
}
cin>>n;
for(i=0;i<n;++i){
cin>>j;
cin>>num1[j];
}
cin>>n;
for(i=0;i<n;++i){
cin>>j;
cin>>num2[j];
}
for(i=0;i<1001;++i){
for(j=0;j<1001;++j){
rest[i+j] += num1[i]*num2[j];
}
}
for(i=0;i<2001;i++){
if(rest[i]!=0)
++count;
}
cout<<count;
for(i=2001;i>=0;--i){
if(rest[i]!=0)	{
cout<<" "<<i<<" ";
printf("%.1f",rest[i]);
}
}
cout<<endl;
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: