您的位置:首页 > 产品设计 > UI/UE

HOJ 1603 Brackets Sequence

2016-03-08 14:54 633 查看


Brackets Sequence

My Tags  (Edit)
 Source : ACM
ICPC Northeastern European Regional 2001
 Time limit : 1 sec Memory limit : 32 M
Submitted : 398, Accepted : 178

Let us define a regular brackets sequence in the following way:

1. Empty sequence is a regular sequence.

2. If S is a regular sequence, then (S) and [S] are both regular sequences.

3. If A and B are regular sequences, then AB is a regular sequence.

For example, all of the following sequences of characters are regular brackets sequences:

(), [], (()), ([]), ()[], ()[()]

And all of the following character sequences are not:

(, [, ), )(, ([)], ([(]

Some sequence of characters '(', ')', '[', and ']' is given. You are to find the shortest possible regular brackets sequence, that contains the given character sequence as a subsequence. Here, a string a1 a2 ... an is called a subsequence of the string b1 b2
... bm, if there exist such indices 1 = i1 < i2 < ... < in = m, that aj = bij for all 1 = j = n.

Input

Input contains several test cases. Each test case contains a single line consisting of at most 100 brackets (characters '(', ')', '[' and ']') that are situated on a single line without any other characters among them.

Process to end of file.

Output

For each test case, write to the output file a single line that contains some regular brackets sequence that has the minimal possible length and contains the given sequence as a subsequence.

Sample Input
([(]

Sample Output
()[()]


题目意思是给定一个括号序列,错误的话就用最少的括号数补全,正确直接输出即可。

大致思想是用动态规划,dp[i][j]表示位置i到位置j所需补全的括号数,c[i][j]表示位置i到位置j需要断开的位置。需要注意的是循环的顺序,外层循环必须从最后开始,因为

dp[i][j]搜索过程中间会用到dp[i][k]和dp[k+1][j]。代码如下:

#include <iostream>
#include <string.h>

using namespace std;
int dp[110][110],c[110][110];
string brac;

void p(int i,int j)
{
if(i>j)
return;
if(i==j)
{
if(brac[i]=='(' || brac[i]==')')
cout<<"()";
else
cout<<"[]";
return;
}
else
{
if(c[i][j]==-1)
{
if(brac[i]=='(')
{
cout<<"(";
p(i+1,j-1);
cout<<")";
}
else
{
cout<<"[";
p(i+1,j-1);
cout<<"]";
}
}
else
{
p(i,c[i][j]);
p(c[i][j]+1,j);
}
}
}

int main()
{

int i,j,k,m,pp;

while(cin>>brac)
{
memset(dp,0,sizeof(dp));
memset(c,-1,sizeof(c));

for(i=0; i<brac.length(); i++)
dp[i][i]=1;
for(i=brac.length()-1; i>=0; i--)
{
for(j=i+1; j<brac.length(); j++)
{
m = 2000;
for(k=i; k<j; k++)
{
if(dp[i][k]+dp[k+1][j] < m)
{
m = dp[i][k]+dp[k+1][j];
c[i][j] = k;
}
}
dp[i][j] = m;
if((brac[i]=='(' && brac[j]==')') || (brac[i]=='[' && brac[j]==']'))//i和j匹配的情况
{
if(dp[i+1][j-1] < m)
{
dp[i][j]=dp[i+1][j-1];
c[i][j]=-1;
}

}

}
}
p(0,brac.length()-1);
cout<<endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: