您的位置:首页 > 其它

1012. The Best Rank (25)

2016-03-08 12:50 357 查看


1012. The Best Rank (25)

时间限制

400 ms

内存限制

65536 kB

代码长度限制

16000 B

判题程序

Standard

作者

CHEN, Yue

To evaluate the performance of our first year CS majored students, we consider their grades of three courses only: C - C Programming Language, M - Mathematics (Calculus or Linear Algebra), and E - English. At the mean time, we encourage students by emphasizing
on their best ranks -- that is, among the four ranks with respect to the three courses and the average grade, we print the best rank for each student.

For example, The grades of C, M, E and A - Average of 4 students are given as the following:
StudentID  C  M  E  A
310101     98 85 88 90
310102     70 95 88 84
310103     82 87 94 88
310104     91 91 91 91


Then the best ranks for all the students are No.1 since the 1st one has done the best in C Programming Language, while the 2nd one in Mathematics, the 3rd one in English, and the last one in average.

Input

Each input file contains one test case. Each case starts with a line containing 2 numbers N and M (<=2000), which are the total number of students, and the number of students who would check their ranks, respectively. Then N lines follow, each contains a student
ID which is a string of 6 digits, followed by the three integer grades (in the range of [0, 100]) of that student in the order of C, M and E. Then there are M lines, each containing a student ID.

Output

For each of the M students, print in one line the best rank for him/her, and the symbol of the corresponding rank, separated by a space.

The priorities of the ranking methods are ordered as A > C > M > E. Hence if there are two or more ways for a student to obtain the same best rank, output the one with the highest priority.

If a student is not on the grading list, simply output "N/A".
Sample Input
5 6
310101 98 85 88
310102 70 95 88
310103 82 87 94
310104 91 91 91
310105 85 90 90
310101
310102
310103
310104
310105
999999

Sample Output
1 C
1 M
1 E
1 A
3 A
N/A


-------------------/*分析*/---------------------------

内存足够可用hash,也可结构体排序,注意排名:如果有2个rank 2,则没有rank 3,直接从rank 4开始。

关键点:由于只需要获得某个grade的rank值,故只要count相同的grade值,然后计算各grade的rank值,最后直接按grade查找rank。

以下是使用hash查找的代码

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
#include <cstdio>
#define MAX 1000000
int id[MAX];
char course[5]="ACME";
int rank[4][102];	//rank[0][i+1]记录grade为i分的排名
int n,m;
int grade[4][2000];
int main(){
scanf("%d%d",&n,&m);
for(int i=0;i<MAX;i++) id[i]=-1;
for(int i=0;i<4;i++){
rank[i][101]=1;
for(int j=0;j<101;j++)
rank[i][j]=0;
}
for(int i=0;i<n;i++){
int num;
scanf("%d",&num);
id[num]=i;
grade[0][i]=0;
for(int j=1;j<4;j++){
int g;
scanf("%d",&g);
grade[j][i]=g;
grade[0][i]+=g;
rank[j][g]++;
}
grade[0][i]/=3;
rank[0][grade[0][i]]++;
}
for(int i=0;i<4;i++){
for(int j=100;j>=0;j--)
rank[i][j]+=rank[i][j+1];
}
for(int i=0;i<m;i++){
int num;
scanf("%d",&num);
int k=id[num];
if(k<0) printf("N/A\n");
else{
int g=grade[0][k];
int best=rank[0][g+1];
int c=0;
for(int j=1;j<4;j++){
g=grade[j][k];
if(best>rank[j][g+1]){
best=rank[j][g+1];
c=j;
}
}
printf("%d %c\n",best,course[c]);
}
}
return 0;
}

评测结果

时间结果得分题目语言用时(ms)内存(kB)用户
3月08日
12:27
答案正确251012C++
(g++ 4.7.2)
44220Kent

测试点

测试点结果用时(ms)内存(kB)得分/满分
0答案正确2413215/15
1答案正确341402/2
2答案正确341362/2
3答案正确341403/3
4答案正确442203/3
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  pat