您的位置:首页 > 其它

【杭电oj】1003 - Max Sum(最大子序列的和)

2016-03-07 17:39 441 查看


Max Sum

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 200098    Accepted Submission(s): 46774


Problem Description

Given a sequence a[1],a[2],a[3]......a
, your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.

 

Input

The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).

 

Output

For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence.
If there are more than one result, output the first one. Output a blank line between two cases.

 

Sample Input

2
5 6 -1 5 4 -7
7 0 6 -1 1 -6 7 -5

 

Sample Output

Case 1:
14 1 4

Case 2:
7 1 6

 

Author

Ignatius.L

WA了好多次,以后做最大子序列的和的时候要注意负数序列的可能。

代码如下:

#include <cstdio>
int main()
{
int u,num = 1;
int n;
int max,sum;
int st,end,t_st,t;
scanf ("%d",&u);
while (u--)
{
max = -11111;
sum = 0;
t_st = 1;
scanf ("%d",&n);
for (int i=1;i<=n;i++)
{
scanf ("%d",&t);
sum += t;
//下面两个if千万不能写反了,之前就是因为这个WA了好多次
//因为可能出现负数的序列,如果两个if写反,那么max永远不会更新
if (sum > max)
{
max = sum;
st = t_st; //只有出现大于前面的子序列的时候,才能对起始点进行赋值
end = i;
}
if (sum < 0)
{
t_st = i+1;
sum = 0;
}
}
printf ("Case %d:\n%d %d %d\n",num++,max,st,end);
if (u)
printf ("\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: