您的位置:首页 > 其它

POJ 1704 (博弈)

2016-03-07 15:49 363 查看
Georgia and Bob

Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 8724 Accepted: 2783
Description

Georgia and Bob decide to play a self-invented game. They draw a row of grids on paper, number the grids from left to right by 1, 2, 3, ..., and place N chessmen on different grids, as shown in the following figure for example: 



Georgia and Bob move the chessmen in turn. Every time a player will choose a chessman, and move it to the left without going over any other chessmen or across the left edge. The player can freely choose number of steps the chessman moves, with the constraint
that the chessman must be moved at least ONE step and one grid can at most contains ONE single chessman. The player who cannot make a move loses the game. 

Georgia always plays first since "Lady first". Suppose that Georgia and Bob both do their best in the game, i.e., if one of them knows a way to win the game, he or she will be able to carry it out. 

Given the initial positions of the n chessmen, can you predict who will finally win the game? 

Input

The first line of the input contains a single integer T (1 <= T <= 20), the number of test cases. Then T cases follow. Each test case contains two lines. The first line consists of one integer N (1 <= N <= 1000), indicating the number of chessmen. The second
line contains N different integers P1, P2 ... Pn (1 <= Pi <= 10000), which are the initial positions of the n chessmen.
Output

For each test case, prints a single line, "Georgia will win", if Georgia will win the game; "Bob will win", if Bob will win the game; otherwise 'Not sure'.
Sample Input
2
3
1 2 3
8
1 5 6 7 9 12 14 17

Sample Output
Bob will win
Georgia will win

Source

POJ Monthly--2004.07.18
题意:在1*n的格子上有n个棋子,两个人轮流将一个棋子向左移动,但是不能移动到前一个棋子或前一个棋子之前,不能移动的人失败。

将相邻的两个棋子之间的距离看成一堆石头,移动后一个棋子相当于从石头堆中取出若干个石头,移动前一个棋子可以通过移动后一个棋子恢复到原来的状态。这样就转化成了NIM游戏。

#include <cstdio>
#include <cstring>
#include <iostream>
#include <algorithm>
using namespace std;
#define maxn 1111

int main () {
int t, n;
int a[maxn];
scanf ("%d", &t);
while (t--) {
scanf ("%d", &n);
for (int i = 1; i <= n; i++) {
scanf ("%d", &a[i]);
}
sort (a+1, a+1+n);
int ans = 0;
if (n&1) {
a[0] = 0;
for (int i = 1; i <= n; i += 2) {
ans ^= (a[i]-a[i-1]-1);
}
}
else {
for (int i = 1; i <= n; i += 2) {
ans ^= (a[i+1]-a[i]-1);
}
}
cout << (ans ? "Georgia will win" : "Bob will win") << endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: