您的位置:首页 > 其它

HDOJ1016(搜索DFS)

2016-03-06 15:47 369 查看

Prime Ring Problem

Time Limit: 4000/2000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 38643 Accepted Submission(s): 17073



[align=left]Problem Description[/align]
A ring is compose of n circles as shown in diagram. Put natural number 1, 2, ..., n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.

Note: the number of first circle should always be 1.



[align=left]Input[/align]
n (0 < n < 20).

[align=left]Output[/align]
The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions
in lexicographical order.

You are to write a program that completes above process.

Print a blank line after each case.

[align=left]Sample Input[/align]

6
8


[align=left]Sample Output[/align]

Case 1:
1 4 3 2 5 6
1 6 5 2 3 4

Case 2:
1 2 3 8 5 6 7 4
1 2 5 8 3 4 7 6
1 4 7 6 5 8 3 2
1 6 7 4 3 8 5 2


此题目是dfs问题,要回回溯

#include<iostream>
#include<cstring>
#include<cstdio>
#include<cmath>
using namespace std;
int n;
int a[21];//存放结果
int sign[21];//用来标记
int isprime[38]={0,0,1,1,0,1,0,1,0,0,0,1,0,1,0,0,0,1,0,1,0,0,0,1,0,0,0,0,0,1,0,1,0,0,0,0,0,1};
void dfs(int m)
{
//结束条件
if(m==n&&isprime[a[n-1]+a[0]])//因为是环,判断最后一位和第一位的和
{
cout << a[0];
for(int i=1;i<n;i++)
cout << " " << a[i];
cout << endl;
}
else
{
for(int i=2;i<=n;i++)
{
if(!sign[i]&&isprime[i+a[m-1]])
{
a[m]=i;
sign[i]=1;//已经用过,标记为1
dfs(m+1);//递归
sign[i]=0;//如果递归回来没有用到这个数,重新标记为可用的
}
}
}
}
int main()
{
int count=0;
a[0]=1;
while(~scanf("%d",&n))
{
memset(sign,0,sizeof(sign));
count++;
cout << "Case " << count <<":" << endl;
dfs(1);
cout << endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: