您的位置:首页 > 其它

hdu1003最大子序 记录起始与终止点

2016-03-05 20:42 357 查看


Max Sum

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 205709 Accepted Submission(s): 48066



Problem Description

Given a sequence a[1],a[2],a[3]......a
, your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.

Input

The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).

Output

For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence.
If there are more than one result, output the first one. Output a blank line between two cases.

Sample Input

2
5 6 -1 5 4 -7
7 0 6 -1 1 -6 7 -5


Sample Output

Case 1:
14 1 4

Case 2:
7 1 6


这一题的升级版
http://blog.csdn.net/summer__show_/article/details/50616608
调试后容易理解

#include<stdio.h>

const int Max=100005;

int tag[Max];

int main()
{
int K,t=1;
scanf("%d",&K);
while(K--)
{
int n;
scanf("%d",&n);
for(int i=1;i<=n;i++)
scanf("%d",&tag[i]);

int start=1,enda=1,tmpStart=1,tmpEnd=1;
int ans=-0xfffffff;
int sum=0;
for(int i=1;i<=n;i++,tmpEnd=i){
sum+=tag[i];
if(sum>ans){
ans=sum;
start=tmpStart;
enda=tmpEnd;
}
if(sum<0){
tmpStart=tmpEnd+1;
sum=0;
}
}
printf("Case %d:\n%d %d %d\n",t++,ans,start,enda);
if(K){
printf("\n");
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: