您的位置:首页 > 产品设计 > UI/UE

Uva1594 Ducci Sequence

2016-03-05 13:52 363 查看

A Ducci sequence is a sequence of n-tuples of integers. Given an n-tuple of integers (a1,a2,···,an), the next n-tuple in the sequence is formed by taking the absolute differences of neighboring integers: (a1,a2,···,an) → (|a1 −a2|,|a2 −a3|,···,|an −a1|) Ducci
sequences either reach a tuple of zeros or fall into a periodic loop. For example, the 4-tuple sequence starting with 8,11,2,7 takes 5 steps to reach the zeros tuple: (8,11,2,7) → (3,9,5,1) → (6,4,4,2) → (2,0,2,4) → (2,2,2,2) → (0,0,0,0). The 5-tuple sequence
starting with 4,2,0,2,0 enters a loop after 2 steps: (4,2,0,2,0) → (2,2,2,2,4) → (0,0,0,2,2) → (0,0,2,0,2) → (0,2,2,2,2) → (2,0,0,0,2) → (2,0,0,2,0) → (2,0,2,2,2) → (2,2,0,0,0) → (0,2,0,0,2) → (2,2,0,2,2) → (0,2,2,0,0) → (2,0,2,0,0) → (2,2,2,0,2) → (0,0,2,2,0)
→ (0,2,0,2,0) → (2,2,2,2,0) → (0,0,0,2,2) →··· Given an n-tuple of integers, write a program to decide if the sequence is reaching to a zeros tuple or a periodic loop.

Input

Your program is to read the input from standard input. The input consists of T test cases. The number of test cases T is given in the first line of the input. Each test case starts with a line containing an integer n (3 ≤ n ≤ 15), which represents the size of
a tuple in the Ducci sequences. In the following line, n integers are given which represents the n-tuple of integers. The range of integers are from 0 to 1,000. You may assume that the maximum number of steps of a Ducci sequence reaching zeros tuple or making
a loop does not exceed 1,000.

Output

Your program is to write to standard output. Print exactly one line for each test case. Print ‘LOOP’ if the Ducci sequence falls into a periodic loop, print ‘ZERO’ if the Ducci sequence reaches to a zeros tuple.

Sample Input

4 4 8 11 2 7 5 4 2 0 2 0 7 0 0 0 0 0 0 0 6 1 2 3 1 2 3

Sample Output

ZERO

LOOP

ZERO

LOOP

设f(i,j)为第i次做|aj-a(j+1)%n|

由题已知最多1000次之后会出现循环或全部为零,所以只需要判断第f(1001,j)(其中j属于1~n)中有没有大于零的数,若有则是LOOP,否则是ZERO;

#include<stdio.h>
#include<algorithm>
using namespace std;
int a[100];
int b[1005][100];
int n;
void f(int ii)
{
for (int kk=0;kk<n;kk++)
{
b[0][kk]=a[kk];
}

for (int i=1;i<=ii;i++)
{
for (int j=0;j<n;j++)
{
b[i][j]=abs(b[i-1][j]-b[i-1][(j+1)%n]);
}
}

}
int main()
{
int t;
scanf("%d",&t);
for (int k=0;k<t;k++)
{
scanf("%d",&n);
for (int i=0;i<n;i++)
{
scanf("%d",&a[i]);
}

f(1001);
int flag=1;
for (int i=0;i<n;i++)
{
if (b[1001][i]>0) {flag=0; break;}
}
if (flag)
{
printf("ZERO\n");
}
else
{
printf("LOOP\n");
}
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: