您的位置:首页 > 其它

hdu 1027 Ignatius and the Princess II

2016-03-04 20:52 417 查看

Ignatius and the Princess II

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 6305 Accepted Submission(s):
3730


[align=left]Problem Description[/align]
Now our hero finds the door to the BEelzebub feng5166.
He opens the door and finds feng5166 is about to kill our pretty Princess. But
now the BEelzebub has to beat our hero first. feng5166 says, "I have three
question for you, if you can work them out, I will release the Princess, or you
will be my dinner, too." Ignatius says confidently, "OK, at last, I will save
the Princess."

"Now I will show you the first problem." feng5166 says,
"Given a sequence of number 1 to N, we define that 1,2,3...N-1,N is the smallest
sequence among all the sequence which can be composed with number 1 to N(each
number can be and should be use only once in this problem). So it's easy to see
the second smallest sequence is 1,2,3...N,N-1. Now I will give you two numbers,
N and M. You should tell me the Mth smallest sequence which is composed with
number 1 to N. It's easy, isn't is? Hahahahaha......"
Can you help Ignatius
to solve this problem?

[align=left]Input[/align]
The input contains several test cases. Each test case
consists of two numbers, N and M(1<=N<=1000, 1<=M<=10000). You may
assume that there is always a sequence satisfied the BEelzebub's demand. The
input is terminated by the end of file.

[align=left]Output[/align]
For each test case, you only have to output the
sequence satisfied the BEelzebub's demand. When output a sequence, you should
print a space between two numbers, but do not output any spaces after the last
number.

[align=left]Sample Input[/align]

6 4

11 8

[align=left]Sample Output[/align]

1 2 3 5 6 4

1 2 3 4 5 6 7 9 8 11 10

[align=left]Author[/align]
Ignatius.L

[align=left]Recommend[/align]
We have carefully selected several similar problems for
you: 1038 1024 1035 1030 1006

运用了一种新的函数,超级方便!!!
函数详见此处: /article/6281830.html

题意:求N个数全排列,顺着数第M个

附上代码:

#include <iostream>
#include <cstdio>
#include <algorithm>
using namespace std;
int main()
{
int i,j,n,m,t;
int a[1001]= {0};
while(~scanf("%d%d",&n,&m))
{
for(i=1; i<=n; i++)
a[i]=i;
t=0;
do
{
t++;
if(t==m)
break;
}
while(next_permutation(a+1,a+n+1));
for(i=1; i<=n; i++)
{
if(i!=1)
printf(" ");
printf("%d",a[i]);
}
printf("\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: