您的位置:首页 > 其它

Palindrome(POJ 1159 DP)

2016-03-04 19:46 323 查看
Palindrome

Time Limit: 3000MSMemory Limit: 65536K
Total Submissions: 58168Accepted: 20180
Description

A palindrome is a symmetrical string, that is, a string read identically from left to right as well as from right to left. You are to write a program which, given a string, determines the minimal number of characters to be inserted into the string in order to obtain a palindrome.

As an example, by inserting 2 characters, the string "Ab3bd" can be transformed into a palindrome ("dAb3bAd" or "Adb3bdA"). However, inserting fewer than 2 characters does not produce a palindrome.
Input

Your program is to read from standard input. The first line contains one integer: the length of the input string N, 3 <= N <= 5000. The second line contains one string with length N. The string is formed from uppercase letters from 'A' to 'Z', lowercase letters from 'a' to 'z' and digits from '0' to '9'. Uppercase and lowercase letters are to be considered distinct.
Output

Your program is to write to standard output. The first line contains one integer, which is the desired minimal number.
Sample Input

5
Ab3bd

Sample Output

2
最少插入多少个字符使得原来的字符串变成回文串DP[i][j]表示长度为i的第j个字符开头的字串需要插入的个数
状态转移方程:(字符串下表以1开始)
  dp[i][j]=dp[i-2][j+1]  如果s[i+j-1]==s[j]
  dp[i][j]=min(dp[i-1][j-1],dp[i-1][j+1])+1 如果不等


#include <cstring>
#include <algorithm>
#include <cstdio>
#include <iostream>
using namespace std;
#define Max 5001
short int dp[Max][Max];
char s[Max];
int main()
{
int len;
int i,j;
freopen("in.txt","r",stdin);
scanf("%d",&len);
scanf("%s",s);
memset(dp,0,sizeof(dp));
for(i=2;i<=len;i++)
{
for(j=0;j<=len-i;j++)
{

if(s[i+j-1]==s[j])
dp[i][j]=dp[i-2][j+1];
else
dp[i][j]=min(dp[i-1][j],dp[i-1][j+1])+1;
}
}
printf("%d\n",dp[len][0]);
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: