您的位置:首页 > 其它

HDU 2594 Simpsons’ Hidden Talents(kmp)

2016-03-04 17:01 183 查看

Simpsons’ Hidden Talents

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 5340 Accepted Submission(s): 1937



[align=left]Problem Description[/align]
Homer: Marge, I just figured out a way to discover some of the talents we weren’t aware we had.

Marge: Yeah, what is it?

Homer: Take me for example. I want to find out if I have a talent in politics, OK?

Marge: OK.

Homer: So I take some politician’s name, say Clinton, and try to find the length of the longest prefix

in Clinton’s name that is a suffix in my name. That’s how close I am to being a politician like Clinton

Marge: Why on earth choose the longest prefix that is a suffix???

Homer: Well, our talents are deeply hidden within ourselves, Marge.

Marge: So how close are you?

Homer: 0!

Marge: I’m not surprised.

Homer: But you know, you must have some real math talent hidden deep in you.

Marge: How come?

Homer: Riemann and Marjorie gives 3!!!

Marge: Who the heck is Riemann?

Homer: Never mind.

Write a program that, when given strings s1 and s2, finds the longest prefix of s1 that is a suffix of s2.

[align=left]Input[/align]
Input consists of two lines. The first line contains s1 and the second line contains s2. You may assume all letters are in lowercase.

[align=left]Output[/align]
Output consists of a single line that contains the longest string that is a prefix of s1 and a suffix of s2, followed by the length of that prefix. If the longest such string is the empty string, then the output should be 0.

The lengths of s1 and s2 will be at most 50000.

[align=left]Sample Input[/align]

clinton
homer
riemann
marjorie


[align=left]Sample Output[/align]

0
rie 3


[align=left]Source[/align]
HDU 2010-05 Programming Contest

//题意:求一个字符串的前缀 和另一个字符串的后缀最多有多少相同的
//所以不要控制模式串的长度,直接循环母串到结束,这样最后一次匹配的
//就刚好是母串的后缀
#include <iostream>
#include <string.h>
#include <algorithm>
#include <cstdio>
#include <math.h>
#include <cstring>
using namespace std;
const int N=50000+10;
char pat
,text
;
int next_
;
int plen,tlen;
inline void getNext(){
int j=0,k=-1;
next_[0]=-1;
while(j<plen){
if(k==-1||pat[j]==pat[k])
next_[++j]=++k;
else
k=next_[k];
}
}
inline int kmp(){
int i=0,j=0;
while(i<tlen){
if(j==-1||text[i]==pat[j])
{
i++;
j++;
}
else{
j=next_[j];
}
}
return j;
}
int main(){
while(gets(pat)){
gets(text);
plen=strlen(pat);
tlen=strlen(text);
getNext();
int re=kmp();
if(re==0)
cout<<0<<endl;
else
{
for(int i=0;i<re;i++)
cout<<pat[i];
cout<<" "<<re<<endl;
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: