您的位置:首页 > 其它

hdu1348 Wall 凸包

2016-03-04 16:16 357 查看


Wall

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 4839 Accepted Submission(s): 1392



Problem Description

Once upon a time there was a greedy King who ordered his chief Architect to build a wall around the King's castle. The King was so greedy, that he would not listen to his Architect's proposals to build a beautiful brick wall with a perfect shape and nice tall
towers. Instead, he ordered to build the wall around the whole castle using the least amount of stone and labor, but demanded that the wall should not come closer to the castle than a certain distance. If the King finds that the Architect has used more resources
to build the wall than it was absolutely necessary to satisfy those requirements, then the Architect will loose his head. Moreover, he demanded Architect to introduce at once a plan of the wall listing the exact amount of resources that are needed to build
the wall.

Your task is to help poor Architect to save his head, by writing a program that will find the minimum possible length of the wall that he could build around the castle to satisfy King's requirements.



The task is somewhat simplified by the fact, that the King's castle has a polygonal shape and is situated on a flat ground. The Architect has already established a Cartesian coordinate system and has precisely measured the coordinates of all castle's vertices
in feet.

Input

The first line of the input file contains two integer numbers N and L separated by a space. N (3 <= N <= 1000) is the number of vertices in the King's castle, and L (1 <= L <= 1000) is the minimal number of feet that King allows for the wall to come close to
the castle.

Next N lines describe coordinates of castle's vertices in a clockwise order. Each line contains two integer numbers Xi and Yi separated by a space (-10000 <= Xi, Yi <= 10000) that represent the coordinates of ith vertex. All vertices are different and the sides
of the castle do not intersect anywhere except for vertices.

Output

Write to the output file the single number that represents the minimal possible length of the wall in feet that could be built around the castle to satisfy King's requirements. You must present the integer number of feet to the King, because the floating numbers
are not invented yet. However, you must round the result in such a way, that it is accurate to 8 inches (1 foot is equal to 12 inches), since the King will not tolerate larger error in the estimates.

This problem contains multiple test cases!

The first line of a multiple input is an integer N, then a blank line followed by N input blocks. Each input block is in the format indicated in the problem description. There is a blank line between input blocks.

The output format consists of N output blocks. There is a blank line between output blocks.

Sample Input

1

9 100
200 400
300 400
300 300
400 300
400 400
500 400
500 200
350 200
200 200


Sample Output

1628


求这些点的凸包的周长,然后加上以要求距离为半径的圆的周长即为所求

#include <cstdio>
#include <iostream>
#include <algorithm>
#include <cmath>

using namespace std;

int n;
const int maxn = 1005;
const double PI = acos(-1);

struct Point {
int x, y;
}p[maxn], stack[maxn];

int cross(Point a, Point b, Point c) {  //ab x ac
return (b.x - a.x) * (c.y - a.y) - (b.y - a.y) * (c.x - a.x);
}

double dis(Point a, Point b) {  //两点距离
return sqrt((a.x - b.x) * (a.x - b.x) + (a.y - b.y) * (a.y - b.y));
}

bool cmp(const Point& a, const Point& b) {  //以p[0]为基准按照极角逆时针排序
int t = cross(p[0], a, b);
if (t < 0 || (t == 0 && dis(p[0], a) > dis(p[0], b)))
return false;
return true;
}

double Gram() {  //凸包Graham算法
int mi = 0, x = p[0].x, y = p[0].y;
for (int i = 1; i < n; i++) {  //找最坐下角的点
if (p[i].x < x || (p[i].x == x && p[i].y < y)) {
mi = i;
x = p[i].x;
y = p[i].y;
}
}
Point tem = p[0];
p[0] = p[mi];
p[mi] = tem;

sort(p + 1, p + n, cmp);  //逆时针排序

p
= p[0];

/*栈初始化,因为排序是逆时针,所以p[0]p[1] x p[0]p[2]
*一定大于等于零,stack[2]可以直接入栈
*/
stack[0] = p[0];
stack[1] = p[1];
stack[2] = p[2];

int top = 2;

for (int i = 3; i <= n; i++) {
//若有右拐且栈内元素大于等于两个,弹出栈顶元素
while (cross(stack[top - 1], stack[top], p[i]) <= 0 && top >= 2) --top;
stack[++top] = p[i];
}
double ans = 0;
for (int i = 0; i < top; i++) {
ans += dis(stack[i], stack[i + 1]);
}
return ans;
}

int main()
{
int T, L;
bool first = true;
scanf("%d", &T);
while (T--) {
scanf("%d%d", &n, &L);
for (int i = 0; i < n; i++)
scanf("%d%d", &p[i].x, &p[i].y);
if (!first)
puts("");
else
first = false;
printf("%.0f\n", Gram() + 2.0 * PI * L);  //凸包周长加上圆周长
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: