您的位置:首页 > 其它

34-题目1176:树查找

2016-03-04 11:44 246 查看

http://ac.jobdu.com/problem.php?pid=1176

题目描述:

有一棵树,输出某一深度的所有节点,有则输出这些节点,无则输出EMPTY。该树是完全二叉树。

输入:

输入有多组数据。

每组输入一个n(1<=n<=1000),然后将树中的这n个节点依次输入,再输入一个d代表深度。

输出:

输出该树中第d层得所有节点,节点间用空格隔开,最后一个节点后没有空格。

样例输入:
4
1 2 3 4
2


样例输出:
2 3


#include<stdio.h>
#include<stdlib.h>
#include<string.h>
#include<math.h>
#include<iostream>
#include<fstream>
using namespace std;

int main()
{
int n, deep;
ifstream cin("data.txt");
while (cin>>n)
{
int *num = new int[n + 1];
int i;
for (i = 1; i <= n; i++)
cin >> num[i];
cin >> deep;
int limit = n > pow(2, deep) - 1 ? pow(2, deep) - 1 : n;  //注意这儿
for (i = pow(2, deep - 1); i < limit; i++)
cout << num[i] << " ";
cout << num[limit] << endl;
}
system("pause");
return 0;

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: