您的位置:首页 > 产品设计 > UI/UE

HDU 2817 A sequence of numbers(快速幂)

2016-03-03 09:40 525 查看

A sequence of numbers

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 4490    Accepted Submission(s): 1418


[align=left]Problem Description[/align]
Xinlv wrote some sequences on the paper a long time ago, they might be arithmetic or geometric sequences. The numbers are not very clear now, and only the first three numbers of each sequence are recognizable.
Xinlv wants to know some numbers in these sequences, and he needs your help.
 

[align=left]Input[/align]
The first line contains an integer N, indicting that there are N sequences. Each of the following N lines contain four integers. The first three indicating the first three numbers of the sequence, and
the last one is K, indicating that we want to know the K-th numbers of the sequence.

You can assume 0 < K <= 10^9, and the other three numbers are in the range [0, 2^63). All the numbers of the sequences are integers. And the sequences are non-decreasing.

 

[align=left]Output[/align]
Output one line for each test case, that is, the K-th number module (%) 200907.
 

[align=left]Sample Input[/align]

2
1 2 3 5
1 2 4 5

 

[align=left]Sample Output[/align]

5
16

分析:

该题目要求是,给你一个数列的前三项,求它的第k项是多少,已知该数列是等差数列或等比数列。

等差数列的时候可以直接算出来,等比数列时需要用到“快速幂”。

该题目比较恶心的地方是一些大数的处理,不注意的话会有一些类型转换。

代码如下:

#include <stdio.h>

long long PowerMod(long long a,long long b,int c,long long q)
{
long long ans=q;
a=a%c;
while(b>0)
{
if(b%2)
ans=(ans*a)%c;
b/=2;
a=(a*a)%c;
}
return ans;
}

int main()
{
long long a,b,c;
int k;
int T;
scanf("%d",&T);
while(T--)
{
scanf("%I64d %I64d %I64d %d",&a,&b,&c,&k);
if(b-a==c-b)
printf("%d\n",(a+(k-1)*(b-a))%200907);
else
printf("%I64d\n",PowerMod(c/b,k-1,200907,a));
}

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: