您的位置:首页 > 其它

hdu2673

2016-03-02 20:22 393 查看

shǎ崽 OrOrOrOrz

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 8268 Accepted Submission(s): 3939



[align=left]Problem Description[/align]
Acmer in HDU-ACM team are ambitious, especially shǎ崽, he can spend time in Internet bar doing problems overnight. So many girls want to meet and Orz him. But Orz him is not that easy.You must solve this problem first.

The problem is :

Give you a sequence of distinct integers, choose numbers as following : first choose the biggest, then smallest, then second biggest, second smallest etc. Until all the numbers was chosen .

For example, give you 1 2 3 4 5, you should output 5 1 4 2 3

[align=left]Input[/align]
There are multiple test cases, each case begins with one integer N(1 <= N <= 10000), following N distinct integers.

[align=left]Output[/align]
Output a sequence of distinct integers described above.

[align=left]Sample Input[/align]

5
1 2 3 4 5


[align=left]Sample Output[/align]

5 1 4 2 3


[align=left]Author[/align]
WhereIsHeroFrom

[align=left]Source[/align]
HDU女生专场公开赛——谁说女子不如男

排序 在两头交替输出就可以了,不过要判断一下奇偶性

#include<stdio.h>
#include<stdlib.h>
int cmp(const void *a, const void *b)
{
return *(int*)a - *(int*)b ;
}
int main()
{
int n, i, j, a[10010];
while(~scanf("%d", &n))
{
for(i=0; i<n; i++)
scanf("%d", &a[i]) ;
qsort(a, n, sizeof(a[0]), cmp) ;
i = 0; j = n - 1 ;
if(n%2!=0)
{
while(j>i)
{
printf("%d %d ", a[j], a[i]) ;
i++; j-- ;
}
printf("%d\n", a[i]) ;
}
else
{
while(j>i+1)
{
printf("%d %d ", a[j], a[i]) ;
i++; j--;
}
printf("%d %d\n", a[j], a[i]) ;
}
}
return 0 ;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: