您的位置:首页 > 其它

hdoj 5505 GT and numbers

2016-03-02 20:15 232 查看

GT and numbers

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/65536 K (Java/Others)

Total Submission(s): 1681 Accepted Submission(s): 428



[align=left]Problem Description[/align]
You are given two numbers
N
and M.

Every step you can get a new N
in the way that multiply N
by a factor of N.

Work out how many steps can N
be equal to M
at least.

If N can't be to M forever,print −1.

[align=left]Input[/align]
In the first line there is a number
T.T
is the test number.

In the next T
lines there are two numbers N
and M.

T≤1000,
1≤N≤1000000,1≤M≤263.

Be careful to the range of M.

You'd better print the enter in the last line when you hack others.

You'd better not print space in the last of each line when you hack others.

[align=left]Output[/align]
For each test case,output an answer.

[align=left]Sample Input[/align]

3
1 1
1 2
2 4


[align=left]Sample Output[/align]

0
-1
1


题意:给出n、m,问n乘以n的质因子是否能够等于m,如果不能输出-1,如果能至少需要乘多少次。

思路:n>m显然无解;

n是乘以它自身的质因子才能等于m,所以m%n肯定等于0,不然无解;

每次乘以gcd(n,m/m)(最大公约数)即可;

由于M<=2^26,要用unsigned long long,不能用long long或__int64。

代码:

#include<stdio.h>
#include<string.h>
#include<algorithm>
#define LL unsigned long long
using namespace std;
int gcd(LL a,LL b)//求最大公约数
{
return b==0?a:gcd(b,a%b);
}
int main()
{
int T;
LL n,m;
scanf("%d",&T);
while(T--)
{
scanf("%I64u%I64u",&n,&m);
int ans=0;
if(n>m||m%n)//无解
printf("-1\n");
else
{
while(n!=m)
{
LL temp=gcd(n,m/n);
if(temp==1)
break;
n*=temp;
ans++;
}
if(n==m)
printf("%d\n",ans);
else
printf("-1\n");
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: