您的位置:首页 > Web前端

hdu 1015 Safecracker

2016-03-02 18:46 363 查看

Safecracker

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 11575 Accepted Submission(s):
5965


[align=left]Problem Description[/align]
=== Op tech briefing, 2002/11/02 06:42 CST ===
"The
item is locked in a Klein safe behind a painting in the second-floor library.
Klein safes are extremely rare; most of them, along with Klein and his factory,
were destroyed in World War II. Fortunately old Brumbaugh from research knew
Klein's secrets and wrote them down before he died. A Klein safe has two
distinguishing features: a combination lock that uses letters instead of
numbers, and an engraved quotation on the door. A Klein quotation always
contains between five and twelve distinct uppercase letters, usually at the
beginning of sentences, and mentions one or more numbers. Five of the uppercase
letters form the combination that opens the safe. By combining the digits from
all the numbers in the appropriate way you get a numeric target. (The details of
constructing the target number are classified.) To find the combination you must
select five letters v, w, x, y, and z that satisfy the following equation, where
each letter is replaced by its ordinal position in the alphabet (A=1, B=2, ...,
Z=26). The combination is then vwxyz. If there is more than one solution then
the combination is the one that is lexicographically greatest, i.e., the one
that would appear last in a dictionary."

v - w^2 + x^3 - y^4 + z^5 =
target

"For example, given target 1 and letter set ABCDEFGHIJKL, one
possible solution is FIECB, since 6 - 9^2 + 5^3 - 3^4 + 2^5 = 1. There are
actually several solutions in this case, and the combination turns out to be
LKEBA. Klein thought it was safe to encode the combination within the engraving,
because it could take months of effort to try all the possibilities even if you
knew the secret. But of course computers didn't exist then."

=== Op tech
directive, computer division, 2002/11/02 12:30 CST ===

"Develop a
program to find Klein combinations in preparation for field deployment. Use
standard test methodology as per departmental regulations. Input consists of one
or more lines containing a positive integer target less than twelve million, a
space, then at least five and at most twelve distinct uppercase letters. The
last line will contain a target of zero and the letters END; this signals the
end of the input. For each line output the Klein combination, break ties with
lexicographic order, or 'no solution' if there is no correct combination. Use
the exact format shown below."

[align=left]Sample Input[/align]

1 ABCDEFGHIJKL

11700519 ZAYEXIWOVU

3072997 SOUGHT

1234567 THEQUICKFROG

0 END

[align=left]Sample Output[/align]

LKEBA

YOXUZ

GHOST

no solution

[align=left]Source[/align]
Mid-Central
USA 2002

[align=left]Recommend[/align]
JGShining | We have carefully selected several
similar problems for you: 1239 1072 1372 1401 1515

很水的搜索题,直接暴力枚举就好。

题意:输入一个数target 和一个字符串 s,在字符串 s 找出一个由5个字符组成的最大字符串使得v - w^2 + x^3 - y^4 + z^5 = target ;

附上代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
using namespace std;
char ch[35],str[35],w[35];
bool visit[30];
int n,len;
void DFS(int k)
{
int i,j,t;
if(k==5)
{
t=(str[0]-'A'+1)-pow(str[1]-'A'+1,2)+pow(str[2]-'A'+1,3)-pow(str[3]-'A'+1,4)+pow(str[4]-'A'+1,5);
if(t==n&&strcmp(str,w)>0)  //求出字典数最大的5位字符串
{
strcpy(w,str);
}
return ;
}
for(i=0; i<len; i++)  //暴力枚举
{
if(!visit[ch[i]-'A'])
{
str[k]=ch[i];
visit[ch[i]-'A']=true;
DFS(k+1);
visit[ch[i]-'A']=false;
}
}
}
int main()
{
int i,j,t,m;
while(~scanf("%d %s",&n,ch))
{
if(n==0&&strcmp(ch,"END")==0)
break;
memset(visit,false,sizeof(visit));
memset(w,'\0',sizeof(w));
len=strlen(ch);
DFS(0);
if(strlen(w)==0) printf("no solution\n");
else printf("%s\n",w);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: