您的位置:首页 > 其它

2016年:杭电A + B Problem II

2016-03-02 18:37 239 查看


A + B Problem II

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 295003 Accepted Submission(s): 56796



[align=left]Problem Description[/align]
I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.

[align=left]Input[/align]
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should
not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.

[align=left]Output[/align]
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the
equation. Output a blank line between two test cases.

[align=left]Sample Input[/align]

2
1 2
112233445566778899 998877665544332211


[align=left]Sample Output[/align]

Case 1:
1 + 2 = 3

Case 2:
112233445566778899 + 998877665544332211 = 1111111111111111110


[align=left]Author[/align]
Ignatius.L
#include <iostream>
#include <string>
#include <stdio.h>
#include <stdlib.h>
#include <cstring>
using namespace std;

int main()
{
int n,l=1,r;
cin>>n;
r=n;
while(n--)
{
string a,b;
cin>>a>>b;
int len1=a.length();
int len2=b.length();
int m[1001],n[1001],q[1001];
memset(m,0,sizeof(m));
memset(n,0,sizeof(n));
memset(q,0,sizeof(q));
int x=0,y=0;
for(int i=len1-1; i>=0; i--)
{
m[i]=a[x]-48;
x++;
}
for(int i=len2-1; i>=0; i--)
{
n[i]=b[y]-48;
y++;
}
int max;
if(len1>len2)
{
max=len1;
}
else
{
max=len2;
}
cout<<"Case "<<l<<":"<<endl;
for(int i=len1-1; i>=0; i--)
{
cout<<m[i];
}
cout<<" + ";
for(int i=len2-1; i>=0; i--)
{
cout<<n[i];
}
cout<<" = ";
for(int i=0; i<max+1; i++)
{
m[i]=m[i]+n[i];

if(m[i]>9)
{
m[i]=m[i]-10;
m[i+1]=1+m[i+1];
}
}

if(m[max-1]>=0)
cout<<m[max-1];
for(int i=max-2; i>=0; i--)
{

cout<<m[i];
}

cout<<endl;
if(l<r)
{
cout<<endl;
}
l++;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: