您的位置:首页 > 其它

BIT2014级软件学院程序设计-22 Treats for the Cows

2016-03-02 16:21 561 查看
Description

FJ has purchased N (1 <= N <= 2000) yummy treats for the cows who get money for giving vast amounts of milk. FJ sells one treat per day and wants to maximize the money he receives over a given period time.

The treats are interesting for many reasons:

The treats are numbered 1..N and stored sequentially in single file in a long box that is open at both ends. On any day, FJ can retrieve one treat from either end of his stash of treats.
Like fine wines and delicious cheeses, the treats improve with age and command greater prices.
The treats are not uniform: some are better and have higher intrinsic value. Treat i has value v(i) (1 <= v(i) <= 1000).
Cows pay more for treats that have aged longer: a cow will pay v(i)*a for a treat of age a.

Given the values v(i) of each of the treats lined up in order of the index i in their box, what is the greatest value FJ can receive for them if he orders their sale optimally?

The first treat is sold on day 1 and has age a=1. Each subsequent day increases the age by 1.
Input

Line 1: A single integer, N

Lines 2..N+1: Line i+1 contains the value of treat v(i)
Output

Line 1: The maximum revenue FJ can achieve by selling the treats
Sample Input
5
1
3
1
5
2

Sample Output
43

Hint

Explanation of the sample:

Five treats. On the first day FJ can sell either treat #1 (value 1) or treat #5 (value 2).

FJ sells the treats (values 1, 3, 1, 5, 2) in the following order of indices: 1, 5, 2, 3, 4, making 1x1 + 2x2 + 3x3 + 4x1 + 5x5 = 43.

也是一道DP的题。每次从头取或者从后取,DP方程也很容易。

#pragma comment(linker, "/STACK:102400000,102400000")
#include<stdio.h>
#include<string.h>
#include<stdlib.h>
#define maxn 2500
int dp[maxn][maxn];
int num[maxn];
int max(int a, int b)
{
if (a > b)
return a;
return b;
}
int main()
{
int n,i,j,flag;
scanf("%d",&n);
for (i = 1; i <= n; i++)
scanf("%d", &num[i]);
for (i = 1;i <= n;i++)
dp[i][i] = num[i] * n;
for (i = 1; i < n;i++)
for (j = 1; j + i <= n; j++)
{
flag = i + j;
dp[j][flag] = max(dp[j + 1][flag] + (n - i)*num[j], dp[j][flag - 1] + (n - i)*num[flag]);
}
printf("%d\n", dp[1]
);
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: