您的位置:首页 > 其它

UVA 11549(计算器谜题)

2016-03-01 23:36 405 查看
题目描述:

Alice got a hold of an old calculator that can display n digits. She was bored enough to come up with

the following time waster.

She enters a number k then repeatedly squares it until the result overflows. When the result

overflows, only the n most significant digits are displayed on the screen and an error flag appears. Alice

can clear the error and continue squaring the displayed number. She got bored by this soon enough,

but wondered:

“Given n and k, what is the largest number I can get by wasting time in this manner?”

Input

The first line of the input contains an integer t (1 ≤ t ≤ 200), the number of test cases. Each test case

contains two integers n (1 ≤ n ≤ 9) and k (0 ≤ k < 10n) where n is the number of digits this calculator

can display k is the starting number.

Output

For each test case, print the maximum number that Alice can get by repeatedly squaring the starting

number as described.

Sample Input

2

1 6

2 99

Sample Output

9

99

题意:

有个老式计算器,只能显示n位数字。现在输入一个整数k,然后反复平方,一直做下去,能得到的最大数是多少。例如,n=1,k=6,那么一次显示:6,3,9,1…

算法:Floyd判圈算法;

ac代码:

#include<iostream>
#include<cstdio>
#include<algorithm>
using namespace std;
int fun(int n,int k);
int a[22];
int main()
{
int cas;
cin >> cas;
while(cas--)
{
int n,k;
cin >> n >> k;
int ans=k;
int k1=k,k2=k;
do
{
k1=fun(n,k1);
k2=fun(n,k2);
ans=max(ans,k2);
k2=fun(n,k2);
ans=max(ans,k2);
}while(k1!=k2);
cout << ans <<endl;
}
return 0;
}
int fun(int n,int k)
{
long long num=(long long)k*k;
int i=0;
while(num)
{
a[i++]=num%10;
num/=10;
}
int ans=0;
n=min(n,i);
for(int j=i-1;j>=i-n;j--)
ans=ans*10+a[j];
return ans;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: