您的位置:首页 > 其它

hdu 1541 Stars【思维】

2016-03-01 12:35 309 查看


Stars

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 7246    Accepted Submission(s): 2840


Problem Description

Astronomers often examine star maps where stars are represented by points on a plane and each star has Cartesian coordinates. Let the level of a star be an amount of the stars that are not higher and not to the right of the given star. Astronomers want to know
the distribution of the levels of the stars. 



For example, look at the map shown on the figure above. Level of the star number 5 is equal to 3 (it's formed by three stars with a numbers 1, 2 and 4). And the levels of the stars numbered by 2 and 4 are 1. At this map there are only one star of the level
0, two stars of the level 1, one star of the level 2, and one star of the level 3. 

You are to write a program that will count the amounts of the stars of each level on a given map.

 

Input

The first line of the input file contains a number of stars N (1<=N<=15000). The following N lines describe coordinates of stars (two integers X and Y per line separated by a space, 0<=X,Y<=32000). There can be only one star at one point of the plane. Stars
are listed in ascending order of Y coordinate. Stars with equal Y coordinates are listed in ascending order of X coordinate.

 

Output

The output should contain N lines, one number per line. The first line contains amount of stars of the level 0, the second does amount of stars of the level 1 and so on, the last line contains amount of stars of the level N-1.

 

Sample Input

5
1 1
5 1
7 1
3 3
5 5

 

Sample Output

1
2
1
1
0

开始觉得是极角排序之后暴力搞,看到网上大神说有用树状数组做的。然后默默看到一篇文章说这个给的点是已经极角排序过了的。那么极角排序的操作就是多余的,并且根据极角排序的原理,那么不用考虑y的存在,最终AC代码:
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int a[33000],x[33000],y[33000];
int i,j,k,l,m,n;
int main()
{
while(scanf("%d",&k)!=EOF)
{
memset(a,0,sizeof(a));
for(j=0;j<k;j++)
{
scanf("%d%d",&x[j],&y[j]);
int cnt=0;
for(l=0;l<j;l++)
if(x[l]<=x[j])
cnt++;
a[cnt]++;
}
for(i=0;i<k;i++)
printf("%d\n",a[i]);

}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  hdu 1541 杭电 1541