您的位置:首页 > 其它

POJ - 2406 Power Strings

2016-02-29 21:29 543 查看

Power Strings

Time Limit: 3000MS Memory Limit: 65536KB 64bit IO Format: %I64d & %I64u
Submit

Status

Description

Given two strings a and b we define a*b to be their concatenation. For example, if a = "abc" and b = "def" then a*b = "abcdef". If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined
in the normal way: a^0 = "" (the empty string) and a^(n+1) = a*(a^n).

Input

Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.

Output

For each s you should print the largest n such that s = a^n for some string a.

Sample Input

abcd
aaaa
ababab
.


Sample Output

1
4
3

考察kmp中nex数组的性质
1,nex[a]=b代表a之前的一段字符和b之前的一段字符相等。
2,如果nex[len-1]=l-2;说明字符串是个形如aaaaa,bbbbb的串
3,如果有循环节,那么nex[len-1]=b时,循环节k为len-1-nex[len-1];若len%k=0,说明循环,否则不循环

#include<iostream>
#include<string.h>
#include<stdio.h>
using namespace std;
int nex[1009904];
char s[1000904];
int l;
int a,b,c,d,n,m;
void getnex()
{
        int j=-1;
        for (int i=0;i<l;i++)
                {
                while(j!=-1 && s[i]!=s[j+1])
                        j=nex[j];
                if (s[i]==s[j+1] && i!=0)
                        j++;
                nex[i]=j;
                }
}

int main()
{
        while(1)
                {
                nex[0]=-1;
                scanf("%s",&s);

                if (s[0]=='.')
                        return 0;
                l=strlen(s);
                getnex();
                int a;
                a=nex[l-1];
                a=l-a-1;
                if (l%a==0)     cout<<l/a<<endl;
                else cout<<1<<endl;

                }
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: