您的位置:首页 > 其它

POJ 1002 487-3279(排序)

2016-02-29 19:39 357 查看

Description
Businesses like to have memorable telephone numbers. One way to make a telephone number memorable is to have it spell a memorable word or phrase. For example, you can call the University of Waterloo by dialing the memorable TUT-GLOP.
Sometimes only part of the number is used to spell a word. When you get back to your hotel tonight you can order a pizza from Gino's by dialing 310-GINO. Another way to make a telephone number memorable is to group the digits in a memorable way. You could
order your pizza from Pizza Hut by calling their ``three tens'' number 3-10-10-10.

The standard form of a telephone number is seven decimal digits with a hyphen between the third and fourth digits (e.g. 888-1200). The keypad of a phone supplies the mapping of letters to numbers, as follows:

A, B, and C map to 2

D, E, and F map to 3

G, H, and I map to 4

J, K, and L map to 5

M, N, and O map to 6

P, R, and S map to 7

T, U, and V map to 8

W, X, and Y map to 9

There is no mapping for Q or Z. Hyphens are not dialed, and can be added and removed as necessary. The standard form of TUT-GLOP is 888-4567, the standard form of 310-GINO is 310-4466, and the standard form of 3-10-10-10 is 310-1010.

Two telephone numbers are equivalent if they have the same standard form. (They dial the same number.)

Your company is compiling a directory of telephone numbers from local businesses. As part of the quality control process you want to check that no two (or more) businesses in the directory have the same telephone number.

Input
The input will consist of one case. The first line of the input specifies the number of telephone numbers in the directory (up to 100,000) as a positive integer alone on the line. The remaining lines list the telephone numbers
in the directory, with each number alone on a line. Each telephone number consists of a string composed of decimal digits, uppercase letters (excluding Q and Z) and hyphens. Exactly seven of the characters in the string will be digits or letters.

Output
Generate a line of output for each telephone number that appears more than once in any form. The line should give the telephone number in standard form, followed by a space, followed by the number of times the telephone number
appears in the directory. Arrange the output lines by telephone number in ascending lexicographical order. If there are no duplicates in the input print the line:

No duplicates.

Sample Input
12
4873279
ITS-EASY
888-4567
3-10-10-10
888-GLOP
TUT-GLOP
967-11-11
310-GINO
F101010
888-1200
-4-8-7-3-2-7-9-
487-3279

Sample Output
310-1010 2
487-3279 4

888-4567 3

这题思路不是很困难大概就是先读入字符数组之后转化为数字,之后排序,统计相同的个数然后输出,但是坑点较多。

需注意以下几点:

1.字符数组要开大些之前开到20结果wa了几发,后来改到50才A的;

2.注意输出不足7位时要补0(eg.0000000 应该输出000-0000而不是0);

3.最后输出的是No duplicates. 不要忘记最后的句号;

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
struct p
{
int countt;
char ch[50];
int b;

}a[100005];
struct pp
{
int ct;
int num;
}aa[100005];
bool cmp1(p aa,p bb)
{
return aa.b<bb.b;
}
int shift(char chr)
{
if (chr>='0'&&chr<='9') {return chr-'0';}
if (chr>='A'&&chr<='C') {return 2;}
if (chr>='D'&&chr<='F') {return 3;}
if (chr>='G'&&chr<='I') {return 4;}
if (chr>='J'&&chr<='L') {return 5;}
if (chr>='M'&&chr<='O') {return 6;}
if (chr>='P'&&chr<='S') {return 7;}
if (chr>='T'&&chr<='V') {return 8;}
if (chr>='W'&&chr<='Y') {return 9;}
}
void shf(int weizhi)
{
int tg=0;int ww=0;
for (int i=0;i<strlen(a[weizhi].ch);i++)
{
if (a[weizhi].ch[i]!='-') {printf("%d",shift(a[weizhi].ch[i]));tg++;}
if (tg==3&&ww==0) {printf("-"); ww=1;}
}
}
int pow(int xx)
{
int s=1;
for (int i=0;i<xx;i++)
{
s=s*10;
}
return s;
}
void f(int pos)
{
int len=strlen(a[pos].ch);
int k=1;
for (int i=0;i<len;i++)
{
if (a[pos].ch[i]=='-') continue;
else
{
a[pos].b=a[pos].b+pow(7-k)*shift(a[pos].ch[i]);
k++;
}
}
}
int main()
{
int n;
scanf("%d",&n);
for (int i=0;i<n;i++)
{
scanf("%s",a[i].ch);
a[i].b=0;
a[i].countt=1;
f(i);
}
sort(a,a+n,cmp1);
int ss=0; a
.b=-1;
for (int i=0;i<n;i++)
{
if (a[i].b==a[i+1].b) {a[i+1].countt=a[i+1].countt+a[i].countt;}
else {aa[ss].ct=a[i].countt;aa[ss].num=i;ss++;}
}
int w=1;
for (int i=0;i<ss;i++)
{
if (aa[i].ct>1)
{
shf(aa[i].num);
w=0;
printf(" %d\n",aa[i].ct);
}

}
if (w) printf("No duplicates.\n");
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: