您的位置:首页 > 其它

hdu1019(快排&&欧几里得)

2016-02-28 22:58 274 查看


Least Common Multiple

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 43104    Accepted Submission(s): 16191


Problem Description

The least common multiple (LCM) of a set of positive integers is the smallest positive integer which is divisible by all the numbers in the set. For example, the LCM of 5, 7 and 15 is 105.

 

Input

Input will consist of multiple problem instances. The first line of the input will contain a single integer indicating the number of problem instances. Each instance will consist of a single line of the form m n1 n2 n3 ... nm where m is the number of integers
in the set and n1 ... nm are the integers. All integers will be positive and lie within the range of a 32-bit integer.

 

Output

For each problem instance, output a single line containing the corresponding LCM. All results will lie in the range of a 32-bit integer.

 

Sample Input

2
3 5 7 15
6 4 10296 936 1287 792 1

 

Sample Output

105
10296

 

Source

East Central North America 2003, Practice

 

//hdu1019(快速排序&&欧几里得求N个数的最小公倍数)
// 首先,sort排好序,求出a[n-1]和a[n-2]的最小公倍数lcm。然后从i=n-3开始,
//依次判断lcm能被a[i]整除,如果可以则跳过判断下一个。否则求出lcm和a[i]的最小公倍数。
//依次最后结果就是n个数的最小公倍数。
#include<cstdio>
#include<cstring>
#include<cstdlib>
#include<algorithm>
using namespace std;
int gcd(int a,int b)    //欧几里得算法
{
if(b==0) return a;
else
{
gcd(b,a%b);
}
}
__int64 a[100010];
int main()
{
int i,j,k,t,n,lcm;
scanf("%d",&t);
while(t--)
{
scanf("%d",&n);
for(i=0;i<n;i++)
scanf("%d",&a[i]);
if(n==1)                //n==1时情况。
{
printf("%d\n",a[0]);
continue;
}
sort(a,a+n);
k=gcd(a[n-1],a[n-2]);
lcm=(a[n-1]/k)*(a[n-2]/k)*k;   //求出a[n-1]和a[n-2]的lcm;
for(i=n-3;i>=0;)
{
if(lcm%a[i]==0)        //lcm可以整除a[i],则跳过。
{
i--;
}
else
{
k=gcd(lcm,a[i]);
lcm=(lcm/k)*(a[i]/k)*k;  //否则,求lcm和a[i]的lcm
i--;
}
}
printf("%d\n",lcm);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: