您的位置:首页 > 其它

1052 Linked List Sorting

2016-02-28 20:05 302 查看
A linked list consists of a series of structures, which are not necessarily adjacent in memory. We assume that each structure contains an integer key and a Next pointer to the next structure. Now given a linked list, you are supposed to sort the structures according to their key values in increasing order.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive N (< 105) and an address of the head node, where N is the total number of nodes in memory and the address of a node is a 5-digit positive integer. NULL is represented by -1.

Then N lines follow, each describes a node in the format:

Address Key Next

where Address is the address of the node in memory, Key is an integer in [-105, 105], and Next is the address of the next node. It is guaranteed that all the keys are distinct and there is no cycle in the linked list starting from the head node.

Output Specification:

For each test case, the output format is the same as that of the input, where N is the total number of nodes in the list and all the nodes must be sorted order.

Sample Input:

5 00001

11111 100 -1

00001 0 22222

33333 100000 11111

12345 -1 33333

22222 1000 12345

Sample Output:

5 12345

12345 -1 00001

00001 0 11111

11111 100 22222

22222 1000 33333

33333 100000 -1

解题思路:注意两个情况:不知一条链表,还有链表为空的情况,所以next属性是有用的。

#include<iostream>
#include<vector>
#include<algorithm>
using namespace std;
struct node{
int key;
int address;
int next;
};
bool cmp(const node n1, const node n2){
return n1.key < n2.key;
}
node ns[100005];
int main(){
for (int n, root; scanf("%d%d", &n, &root) != EOF;){
vector<node>nodes;
for (int i = 0; i < n; i++){
int address;
scanf("%d", &address);
scanf("%d %d", &ns[address].key, &ns[address].next);
ns[address].address = address;
}
while (root != -1){
nodes.push_back(ns[root]);
root = ns[root].next;
}
sort(nodes.begin(), nodes.end(),cmp);
if (nodes.size()){
printf("%d %05d\n", nodes.size(), nodes[0].address);
for (int i = 0; i < nodes.size() - 1; i++){
printf("%05d %d %05d\n", nodes[i].address, nodes[i].key, nodes[i + 1].address);
}
printf("%05d %d -1\n", nodes[nodes.size() - 1].address, nodes[nodes.size() - 1].key);
}
else{
printf("%d -1\n", nodes.size());
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: