您的位置:首页 > 其它

POJ 1847 - Tram

2016-02-28 11:35 204 查看
N - Tram
Time Limit:1000MS Memory Limit:30000KB 64bit IO Format:%I64d
& %I64u
Submit Status Practice POJ
1847

Appoint description:
System Crawler (2016-02-21)

Description

Tram network in Zagreb consists of a number of intersections and rails connecting some of them. In every intersection there is a switch pointing to the one of the rails going out of the intersection. When the tram enters the intersection it can leave only in
the direction the switch is pointing. If the driver wants to go some other way, he/she has to manually change the switch.

When a driver has do drive from intersection A to the intersection B he/she tries to choose the route that will minimize the number of times he/she will have to change the switches manually.

Write a program that will calculate the minimal number of switch changes necessary to travel from intersection A to intersection B.

Input

The first line of the input contains integers N, A and B, separated by a single blank character, 2 <= N <= 100, 1 <= A, B <= N, N is the number of intersections in the network, and intersections are numbered from 1 to N.

Each of the following N lines contain a sequence of integers separated by a single blank character. First number in the i-th line, Ki (0 <= Ki <= N-1), represents the number of rails going out of the i-th intersection. Next Ki numbers represents the intersections
directly connected to the i-th intersection.Switch in the i-th intersection is initially pointing in the direction of the first intersection listed.

Output

The first and only line of the output should contain the target minimal number. If there is no route from A to B the line should contain the integer "-1".

Sample Input

3 2 1
2 2 3
2 3 1
2 1 2


Sample Output

0


直接指向的边权值为0,需要旋转的边权值为1,用floyd求解

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
using namespace std;

#define N 105
#define ll __int64
#define INF 0x3f3f3f3f

int g

;
int u,v,n;

int main(){
memset(g,INF,sizeof(g));
while (~scanf("%d%d%d",&n,&u,&v)){
for (int i=1;i<=n;i++){
g[i][i]=0;
int m;
scanf("%d",&m);
if (!m) continue;
int temp;
scanf("%d",&temp);
g[i][temp]=0;
for (int j=1;j<m;j++){
scanf("%d",&temp);
g[i][temp]=1;
}
}

for (int k=1;k<=n;k++){
for (int i=1;i<=n;i++){
for (int j=1;j<=n;j++){
if (g[i][j]>g[i][k]+g[k][j])
g[i][j]=g[i][k]+g[k][j];
}
}
}
if (g[u][v]==INF)
printf("-1\n");
else
printf("%d\n",g[u][v]);
}

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: